summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-23 12:19:54 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-23 12:19:54 +0000
commitffeb55d75434c469be9aa3a13f69df5bbe4cb0c4 (patch)
tree35bb7187a691a54cd9b11c5df9e5663247b71247 /dev-games/clanlib
parentMigrated to new Java build system. (diff)
downloadgentoo-2-ffeb55d75434c469be9aa3a13f69df5bbe4cb0c4.tar.gz
gentoo-2-ffeb55d75434c469be9aa3a13f69df5bbe4cb0c4.tar.bz2
gentoo-2-ffeb55d75434c469be9aa3a13f69df5bbe4cb0c4.zip
Version bump #130963 by Andrija Prcic / #146376 by Pacho Ramos.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog7
-rw-r--r--dev-games/clanlib/clanlib-0.8.0.ebuild66
-rw-r--r--dev-games/clanlib/files/digest-clanlib-0.8.03
3 files changed, 75 insertions, 1 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 9bf92d6ad51c..eb7407e74c74 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/clanlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.36 2006/09/13 23:04:45 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.37 2006/09/23 12:19:54 vapier Exp $
+
+*clanlib-0.8.0 (23 Sep 2006)
+
+ 23 Sep 2006; Mike Frysinger <vapier@gentoo.org> +clanlib-0.8.0.ebuild:
+ Version bump #130963 by Andrija Prcic / #146376 by Pacho Ramos.
*clanlib-0.6.5-r4 (13 Sep 2006)
diff --git a/dev-games/clanlib/clanlib-0.8.0.ebuild b/dev-games/clanlib/clanlib-0.8.0.ebuild
new file mode 100644
index 000000000000..9c2ffdca4171
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.0.ebuild,v 1.1 2006/09/23 12:19:54 vapier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-${PV:0:3}/ClanLib-${PV}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0.8"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="opengl sdl vorbis doc mikmod ipv6"
+
+# opengl keyword does not drop the GL/GLU requirement.
+# Autoconf files need to be fixed
+RDEPEND="media-libs/libpng
+ media-libs/jpeg
+ virtual/opengl
+ virtual/glu
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ )
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ mikmod? ( >=media-libs/libmikmod-3.1.9 )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_compile() {
+ #clanSound only controls mikmod/vorbis so there's
+ # no need to pass --{en,dis}able-clanSound ...
+ #clanDisplay only controls X, SDL, OpenGL plugins
+ # so no need to pass --{en,dis}able-clanDisplay
+ # also same reason why we don't have to use clanGUI
+ econf \
+ --enable-dyn \
+ --enable-clanNetwork \
+ --disable-dependency-tracking \
+ $(use_enable x86 asm386) \
+ $(use_enable doc docs) \
+ $(use_enable opengl clanGL) \
+ $(use_enable sdl clanSDL) \
+ $(use_enable vorbis clanVorbis) \
+ $(use_enable mikmod clanMikMod) \
+ $(use_enable ipv6 getaddr) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/clanlib/* "${D}"/usr/share/doc/${PF}/html/ || die
+ rm -rf "${D}"/usr/share/doc/clanlib
+ cp -r Examples "${D}"/usr/share/doc/${PF}/ || die
+ fi
+ dodoc CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux
+}
diff --git a/dev-games/clanlib/files/digest-clanlib-0.8.0 b/dev-games/clanlib/files/digest-clanlib-0.8.0
new file mode 100644
index 000000000000..8623be21921d
--- /dev/null
+++ b/dev-games/clanlib/files/digest-clanlib-0.8.0
@@ -0,0 +1,3 @@
+MD5 3e183a801a31f646b012db2d82f97ff3 ClanLib-0.8.0.tgz 7527581
+RMD160 b78a86b853c12295fcf7d755c59183965bd563ac ClanLib-0.8.0.tgz 7527581
+SHA256 def9bdbb20ea740e005134a77def721e969e230740e67937cc3ac201033059e6 ClanLib-0.8.0.tgz 7527581