summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2013-12-15 18:45:50 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2013-12-15 18:45:50 +0000
commitd85cb936456f191fcd53c09bc806cbfb93861464 (patch)
treedc4d110f20026b27b57d46f0d73d3a518008e2da /dev-embedded
parentVersion bump (bugs #479556 and #486970). (diff)
downloadgentoo-2-d85cb936456f191fcd53c09bc806cbfb93861464.tar.gz
gentoo-2-d85cb936456f191fcd53c09bc806cbfb93861464.tar.bz2
gentoo-2-d85cb936456f191fcd53c09bc806cbfb93861464.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/gpsim/ChangeLog10
-rw-r--r--dev-embedded/gpsim/gpsim-0.27.0.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-embedded/gpsim/ChangeLog b/dev-embedded/gpsim/ChangeLog
index ac4e7b6ed56d..51417957847b 100644
--- a/dev-embedded/gpsim/ChangeLog
+++ b/dev-embedded/gpsim/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/gpsim
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.61 2012/08/05 08:37:23 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.62 2013/12/15 18:45:50 rafaelmartins Exp $
+
+*gpsim-0.27.0 (15 Dec 2013)
+
+ 15 Dec 2013; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gpsim-0.27.0.ebuild:
+ Version bump.
05 Aug 2012; Samuli Suominen <ssuominen@gentoo.org> gpsim-0.26.1.ebuild:
Use virtual/yacc. Block dev-embedded/gpsim-lcd because the libgpsim_lcd
diff --git a/dev-embedded/gpsim/gpsim-0.27.0.ebuild b/dev-embedded/gpsim/gpsim-0.27.0.ebuild
new file mode 100644
index 000000000000..65a7aef17836
--- /dev/null
+++ b/dev-embedded/gpsim/gpsim-0.27.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.27.0.ebuild,v 1.1 2013/12/15 18:45:50 rafaelmartins Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
+HOMEPAGE="http://gpsim.sourceforge.net"
+SRC_URI="mirror://sourceforge/gpsim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc gtk static-libs"
+
+RDEPEND=">=dev-embedded/gputils-0.12
+ !dev-embedded/gpsim-lcd
+ dev-libs/glib:2
+ dev-libs/popt
+ sys-libs/readline
+ gtk? ( >=x11-libs/gtk+extra-2 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc"
+
+DOCS="ANNOUNCE AUTHORS ChangeLog HISTORY PROCESSORS README README.MODULES TODO"
+
+src_configure() {
+ econf \
+ $(use_enable gtk gui) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/gpsim.pdf
+
+ prune_libtool_files
+}