summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-13 22:10:33 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-13 22:10:33 +0000
commitd230e33987b3ba15beade8e3ce7890a2727fc35f (patch)
tree9ba2c66fa028d6cbd8ebd44e63820dd3693a92d2 /dev-embedded
parentAdd desktop menu entries. (diff)
downloadgentoo-2-d230e33987b3ba15beade8e3ce7890a2727fc35f.tar.gz
gentoo-2-d230e33987b3ba15beade8e3ce7890a2727fc35f.tar.bz2
gentoo-2-d230e33987b3ba15beade8e3ce7890a2727fc35f.zip
Version bump for bug #310971. Install docs properly (bug #295095), bump to EAPI 4, and change doc USE flag to examples.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/gnusim8085/ChangeLog11
-rw-r--r--dev-embedded/gnusim8085/files/gnusim8085-1.3.6-makefile.patch23
-rw-r--r--dev-embedded/gnusim8085/gnusim8085-1.3.6.ebuild42
3 files changed, 74 insertions, 2 deletions
diff --git a/dev-embedded/gnusim8085/ChangeLog b/dev-embedded/gnusim8085/ChangeLog
index 0778bce91708..dbc3089af3bd 100644
--- a/dev-embedded/gnusim8085/ChangeLog
+++ b/dev-embedded/gnusim8085/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-embedded/gnusim8085
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gnusim8085/ChangeLog,v 1.17 2009/06/08 17:10:38 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gnusim8085/ChangeLog,v 1.18 2011/02/13 22:10:33 radhermit Exp $
+
+*gnusim8085-1.3.6 (13 Feb 2011)
+
+ 13 Feb 2011; Tim Harder <radhermit@gentoo.org> +gnusim8085-1.3.6.ebuild,
+ +files/gnusim8085-1.3.6-makefile.patch:
+ Version bump for bug #310971. Install docs properly (bug #295095), bump to
+ EAPI 4, and change doc USE flag to examples.
*gnusim8085-1.3.5 (08 Jun 2009)
diff --git a/dev-embedded/gnusim8085/files/gnusim8085-1.3.6-makefile.patch b/dev-embedded/gnusim8085/files/gnusim8085-1.3.6-makefile.patch
new file mode 100644
index 000000000000..ad4db47111ea
--- /dev/null
+++ b/dev-embedded/gnusim8085/files/gnusim8085-1.3.6-makefile.patch
@@ -0,0 +1,23 @@
+--- gnusim8085-1.3.6/Makefile.am.orig
++++ gnusim8085-1.3.6/Makefile.am
+@@ -3,18 +3,9 @@
+ ## If you don't want it to overwrite it,
+ ## Please disable it in the Anjuta project configuration
+
+-SUBDIRS = po src pixmaps doc data
++SUBDIRS = po src pixmaps data
+
+-gnusim8085_docdir = $(docdir)
+-gnusim8085_doc_DATA = \
+- README\
+- AUTHORS\
+- ChangeLog\
+- NEWS\
+- TODO\
+- ABOUT-NLS
+-
+-EXTRA_DIST = config.rpath m4/ChangeLog $(gnusim8085doc_DATA)
++EXTRA_DIST = config.rpath m4/ChangeLog
+
+ DISTCLEANFILES = *.exe *.gz
+
diff --git a/dev-embedded/gnusim8085/gnusim8085-1.3.6.ebuild b/dev-embedded/gnusim8085/gnusim8085-1.3.6.ebuild
new file mode 100644
index 000000000000..1bbd733f6e66
--- /dev/null
+++ b/dev-embedded/gnusim8085/gnusim8085-1.3.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gnusim8085/gnusim8085-1.3.6.ebuild,v 1.1 2011/02/13 22:10:33 radhermit Exp $
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A GTK2 8085 Simulator"
+HOMEPAGE="http://gnusim8085.org"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls examples"
+
+DEPEND=">=x11-libs/gtk+-2.12
+ x11-libs/gtksourceview:2.0
+ nls? ( >=sys-devel/gettext-0.10.40 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default_src_install
+
+ doman doc/gnusim8085.1
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*.asm doc/asm-guide.txt
+ fi
+}