summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-21 17:40:04 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-21 17:40:04 +0000
commitc6757815ce731d5cbc2a791501fb9061c1912bab (patch)
tree4f6c01db19eeaa69d75537a44ee2040a5dae9b93 /dev-dotnet
parentFix bug 329225 (diff)
downloadgentoo-2-c6757815ce731d5cbc2a791501fb9061c1912bab.tar.gz
gentoo-2-c6757815ce731d5cbc2a791501fb9061c1912bab.tar.bz2
gentoo-2-c6757815ce731d5cbc2a791501fb9061c1912bab.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/xsp/ChangeLog7
-rw-r--r--dev-dotnet/xsp/xsp-2.6.5.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index e2ea423b5d4f..8c9419d62acb 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.81 2010/07/12 17:44:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.82 2010/07/21 17:40:04 pacho Exp $
+
+*xsp-2.6.5 (21 Jul 2010)
+
+ 21 Jul 2010; Pacho Ramos <pacho@gentoo.org> +xsp-2.6.5.ebuild:
+ Version bump
12 Jul 2010; Christian Faulhammer <fauli@gentoo.org> xsp-2.6.4.ebuild:
stable x86, bug 327279
diff --git a/dev-dotnet/xsp/xsp-2.6.5.ebuild b/dev-dotnet/xsp/xsp-2.6.5.ebuild
new file mode 100644
index 000000000000..1b4008415788
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-2.6.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.6.5.ebuild,v 1.1 2010/07/21 17:40:04 pacho Exp $
+
+EAPI=2
+
+inherit go-mono mono
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_preinst() {
+ enewgroup aspnet
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+ mv_command="cp -ar" go-mono_src_install
+ newinitd "${PATCHDIR}"/xsp.initd xsp || die
+ newinitd "${PATCHDIR}"/mod-mono-server.initd mod-mono-server || die
+ newconfd "${PATCHDIR}"/xsp.confd xsp || die
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server || die
+
+ keepdir /var/run/aspnet
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}