summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-12-12 20:40:22 +0000
committerMichał Górny <mgorny@gentoo.org>2011-12-12 20:40:22 +0000
commitce9d864400b4a765f11f87ba06da2a29f82d67ce (patch)
treeda82e1a482cae232c4db46ea6b5ab41574698b33 /dev-dotnet/pe-format
parentwhitespace (diff)
downloadgentoo-2-ce9d864400b4a765f11f87ba06da2a29f82d67ce.tar.gz
gentoo-2-ce9d864400b4a765f11f87ba06da2a29f82d67ce.tar.bz2
gentoo-2-ce9d864400b4a765f11f87ba06da2a29f82d67ce.zip
Version bump. The new version installs .desktop file for file manager association.
(Portage version: 2.2.0_alpha79_p31/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet/pe-format')
-rw-r--r--dev-dotnet/pe-format/ChangeLog9
-rw-r--r--dev-dotnet/pe-format/metadata.xml18
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.1.ebuild36
3 files changed, 53 insertions, 10 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index baa9b7263412..5f9d714eb138 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/pe-format
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.33 2011/12/11 09:15:56 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.34 2011/12/12 20:40:22 mgorny Exp $
+
+*pe-format-2.1.1 (12 Dec 2011)
+
+ 12 Dec 2011; Michał Górny <mgorny@gentoo.org> +pe-format-2.1.1.ebuild,
+ metadata.xml:
+ Version bump. The new version installs .desktop file for file manager
+ association.
11 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> pe-format-2.1.ebuild:
x86 stable wrt bug #389183
diff --git a/dev-dotnet/pe-format/metadata.xml b/dev-dotnet/pe-format/metadata.xml
index 459aaad6dc08..69efd9af8821 100644
--- a/dev-dotnet/pe-format/metadata.xml
+++ b/dev-dotnet/pe-format/metadata.xml
@@ -1,16 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>dotnet</herd>
-<maintainer restrict="&gt;=dev-dotnet/pe-format-2">
- <email>mgorny@gentoo.org</email>
- <name>Michał Górny</name>
-</maintainer>
-<upstream>
- <maintainer restrict="&gt;=dev-dotnet/pe-format-2" status="active">
+ <herd>dotnet</herd>
+ <maintainer>
<email>mgorny@gentoo.org</email>
<name>Michał Górny</name>
</maintainer>
- <bugs-to>http://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%20Linux&amp;component=Applications&amp;short_desc=dev-dotnet/pe-format:%20</bugs-to>
-</upstream>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://github.com/mgorny/pe-format2/issues/</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/dev-dotnet/pe-format/pe-format-2.1.1.ebuild b/dev-dotnet/pe-format/pe-format-2.1.1.ebuild
new file mode 100644
index 000000000000..7f05cc438460
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.1.1.ebuild,v 1.1 2011/12/12 20:40:22 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils fdo-mime systemd
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://github.com/mgorny/pe-format2/"
+SRC_URI="mirror://github/mgorny/${PN}2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ systemd_to_myeconfargs
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ fdo-mime_desktop_database_update
+}