summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-06-21 23:54:38 +0000
committerPeter Johanson <latexer@gentoo.org>2005-06-21 23:54:38 +0000
commitefebe24dd9a5921d541327340fc7a2275bca2e8c (patch)
tree00af7f060e873e3a38b6fe0b163e4f0b723c8929 /dev-dotnet/libgdiplus/files
parentVersion bump. (diff)
downloadgentoo-2-efebe24dd9a5921d541327340fc7a2275bca2e8c.tar.gz
gentoo-2-efebe24dd9a5921d541327340fc7a2275bca2e8c.tar.bz2
gentoo-2-efebe24dd9a5921d541327340fc7a2275bca2e8c.zip
Bumpity bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-dotnet/libgdiplus/files')
-rw-r--r--dev-dotnet/libgdiplus/files/digest-libgdiplus-1.1.81
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-1.1.8-giflib.diff60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-dotnet/libgdiplus/files/digest-libgdiplus-1.1.8 b/dev-dotnet/libgdiplus/files/digest-libgdiplus-1.1.8
new file mode 100644
index 000000000000..ab2f76ac877d
--- /dev/null
+++ b/dev-dotnet/libgdiplus/files/digest-libgdiplus-1.1.8
@@ -0,0 +1 @@
+MD5 8b43da0990e43f2e92b7a2bdeb86f725 libgdiplus-1.1.8.tar.gz 1353269
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-1.1.8-giflib.diff b/dev-dotnet/libgdiplus/files/libgdiplus-1.1.8-giflib.diff
new file mode 100644
index 000000000000..2b8f1553a532
--- /dev/null
+++ b/dev-dotnet/libgdiplus/files/libgdiplus-1.1.8-giflib.diff
@@ -0,0 +1,60 @@
+diff -aur libgdiplus-1.1.8-orig/configure.in libgdiplus-1.1.8/configure.in
+--- libgdiplus-1.1.8-orig/configure.in 2005-06-10 12:12:34.000000000 -0400
++++ libgdiplus-1.1.8/configure.in 2005-06-21 19:23:45.000000000 -0400
+@@ -138,7 +138,7 @@
+ AC_ARG_WITH(libtiff,
+ [AC_HELP_STRING([--without-libtiff], [disable TIFF file IO])])
+ AC_ARG_WITH(libungif,
+- [AC_HELP_STRING([--without-libungif], [disable GIF file IO])])
++ [AC_HELP_STRING([--without-libgif], [disable GIF file IO])])
+ AC_ARG_WITH(libpng,
+ [AC_HELP_STRING([--without-libpng], [disable PNG file IO])])
+
+@@ -195,17 +195,17 @@
+ fi
+
+ dnl Test for libungif
+- if test x$with_libungif != xno && test -z "$LIBUNGIF"; then
+- AC_CHECK_LIB(ungif, DGifOpenFileName,
++ if test x$with_libgif != xno && test -z "$LIBGIF"; then
++ AC_CHECK_LIB(gif, DGifOpenFileName,
+ [AC_CHECK_HEADER(gif_lib.h,
+- UNGIF='ungif'; LIBUNGIF='-lungif',
+- AC_MSG_WARN(*** GIF loader will not be built (ungiflibrary not found) ***))],
+- AC_MSG_WARN(*** GIF loader will not be built (ungiflibrary not found) ***))
++ GIF='ungif'; LIBGIF='-lgif',
++ AC_MSG_WARN(*** GIF loader will not be built (giflibrary not found) ***))],
++ AC_MSG_WARN(*** GIF loader will not be built (giflibrary not found) ***))
+ fi
+
+-if test x$UNGIF != x; then
+- GDIPLUS_LIBS="$GDIPLUS_LIBS $LIBUNGIF"
+- AC_DEFINE(HAVE_LIBUNGIF, 1, Define if gif support is available)
++if test x$GIF != x; then
++ GDIPLUS_LIBS="$GDIPLUS_LIBS $LIBGIF"
++ AC_DEFINE(HAVE_LIBGIF, 1, Define if gif support is available)
+ fi
+
+ dnl Test for libpng
+@@ -276,7 +276,7 @@
+ echo $ECHO_N " - JPEG: "
+ test ! x$JPEG = x && echo yes || echo "no (Get it from http://freshmeat.net/projects/libjpeg)"
+ echo $ECHO_N " - GIF: "
+-test ! x$UNGIF = x && echo yes || echo "no (See http://sourceforge.net/projects/libungif)"
++test ! x$GIF = x && echo yes || echo "no (See http://sourceforge.net/projects/libungif)"
+ echo $ECHO_N " - PNG: "
+ test ! x$PNG = x && echo yes || echo "no (See http://www.libpng.org/pub/png/libpng.html)"
+ echo ""
+diff -aur libgdiplus-1.1.8-orig/src/gifcodec.c libgdiplus-1.1.8/src/gifcodec.c
+--- libgdiplus-1.1.8-orig/src/gifcodec.c 2005-06-13 15:17:10.000000000 -0400
++++ libgdiplus-1.1.8/src/gifcodec.c 2005-06-21 19:23:02.000000000 -0400
+@@ -35,7 +35,7 @@
+ #include "gdipImage.h"
+ #include "gifcodec.h"
+
+-#ifdef HAVE_LIBUNGIF
++#ifdef HAVE_LIBGIF
+
+ #include <gif_lib.h>
+
+Only in libgdiplus-1.1.8/src: gifcodec.c.orig