summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-11-28 00:21:32 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-11-28 00:21:32 +0000
commitff9e0ced47ff1d7ec35870057c1cc93da3cc17d5 (patch)
treee1c05092385b62392e739f2d593a85566ae86780 /dev-dotnet/gconf-sharp
parentBump to fix pkgconfig reporting erroneous --libs. (diff)
downloadgentoo-2-ff9e0ced47ff1d7ec35870057c1cc93da3cc17d5.tar.gz
gentoo-2-ff9e0ced47ff1d7ec35870057c1cc93da3cc17d5.tar.bz2
gentoo-2-ff9e0ced47ff1d7ec35870057c1cc93da3cc17d5.zip
Bump to fix pkgconfig reporting erroneous --libs.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc4 x86_64)
Diffstat (limited to 'dev-dotnet/gconf-sharp')
-rw-r--r--dev-dotnet/gconf-sharp/ChangeLog8
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-2.24.0-r1.ebuild21
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild34
3 files changed, 28 insertions, 35 deletions
diff --git a/dev-dotnet/gconf-sharp/ChangeLog b/dev-dotnet/gconf-sharp/ChangeLog
index aa9bae28dc42..110c5c23145e 100644
--- a/dev-dotnet/gconf-sharp/ChangeLog
+++ b/dev-dotnet/gconf-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gconf-sharp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.56 2008/11/26 10:53:24 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.57 2008/11/28 00:21:32 loki_val Exp $
+
+*gconf-sharp-2.24.0-r1 (27 Nov 2008)
+
+ 27 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
+ -gconf-sharp-2.24.0.ebuild, +gconf-sharp-2.24.0-r1.ebuild:
+ Bump to fix pkgconfig reporting erroneous --libs.
26 Nov 2008; Peter Alfredsen <loki_val@gentoo.org>
gconf-sharp-2.24.0.ebuild:
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0-r1.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0-r1.ebuild
new file mode 100644
index 000000000000..9cd7e60c9a50
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0-r1.ebuild,v 1.1 2008/11/28 00:21:32 loki_val Exp $
+
+EAPI=2
+
+GTK_SHARP_MODULE="gnome"
+GTK_SHARP_MODULE_DEPS="art"
+GTK_SHARP_REQUIRED_VERSION="2.12"
+
+inherit gtk-sharp-module
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~x86-fbsd ~amd64"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.24
+ >=dev-dotnet/gtk-sharp-2.12.6[glade]
+ >=dev-dotnet/gnome-sharp-${PV}
+ >=dev-dotnet/art-sharp-${PV}"
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild
deleted file mode 100644
index 9910407d88bc..000000000000
--- a/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-2.24.0.ebuild,v 1.2 2008/11/26 10:53:24 loki_val Exp $
-
-EAPI=2
-
-GTK_SHARP_MODULE="gnome"
-GTK_SHARP_MODULE_DEPS="art"
-GTK_SHARP_REQUIRED_VERSION="2.12"
-
-inherit gtk-sharp-module
-
-SLOT="2"
-KEYWORDS="~x86 ~ppc ~sparc ~x86-fbsd ~amd64"
-IUSE=""
-
-DEPEND="${DEPEND}
- >=gnome-base/gconf-2.24
- >=dev-dotnet/gtk-sharp-2.12.6[glade]
- >=dev-dotnet/gnome-sharp-${PV}
- >=dev-dotnet/art-sharp-${PV}"
-
-src_prepare() {
- gtk-sharp-module_src_prepare
-
- # The makefile for GConf.PropertyEditors references two dll's which will
- # not be built in our case because of the splitting of gnome-sharp;
- # reference their system-installed counterparts instead.
- # TODO: Should this be in the eclass? If no, the other fix for gconf-sharp
- # in the eclass should be moved here as well.
- sed -i -e "s:\$(top_builddir)/art/art-sharp.dll:${GTK_SHARP_LIB_DIR}/art-sharp.dll:" \
- -e "s:\$(top_builddir)/gnome/gnome-sharp.dll:${GTK_SHARP_LIB_DIR}/gnome-sharp.dll:" \
- "${S}"/gconf/GConf.PropertyEditors/Makefile.in || die "sed failed"
-}