summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-07-07 23:56:33 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-07-07 23:56:33 +0000
commitecda2db6531b6931175bc02737e72f8e7fdfd88d (patch)
tree510c8dab847fd97854cf3ca25954e2584826c0fd /dev-db
parentVersion bump. (diff)
downloadgentoo-2-ecda2db6531b6931175bc02737e72f8e7fdfd88d.tar.gz
gentoo-2-ecda2db6531b6931175bc02737e72f8e7fdfd88d.tar.bz2
gentoo-2-ecda2db6531b6931175bc02737e72f8e7fdfd88d.zip
Rev bump for slot dependency on Go
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/etcd/ChangeLog7
-rw-r--r--dev-db/etcd/etcd-2.0.10-r1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-db/etcd/ChangeLog b/dev-db/etcd/ChangeLog
index 71ad9298e781..9b8fcce51182 100644
--- a/dev-db/etcd/ChangeLog
+++ b/dev-db/etcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/etcd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/etcd/ChangeLog,v 1.4 2015/06/06 09:50:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/etcd/ChangeLog,v 1.5 2015/07/07 23:56:33 williamh Exp $
+
+*etcd-2.0.10-r1 (07 Jul 2015)
+
+ 07 Jul 2015; William Hubbs <williamh@gentoo.org> +etcd-2.0.10-r1.ebuild:
+ Rev bump for slot dependency on Go
06 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-db/etcd/etcd-2.0.10-r1.ebuild b/dev-db/etcd/etcd-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..4ad2ced3b2ea
--- /dev/null
+++ b/dev-db/etcd/etcd-2.0.10-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/etcd/etcd-2.0.10-r1.ebuild,v 1.1 2015/07/07 23:56:33 williamh Exp $
+
+EAPI=5
+
+inherit user systemd
+
+KEYWORDS="~amd64"
+DESCRIPTION="A highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/coreos/etcd/"
+SRC_URI="https://github.com/coreos/etcd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc"
+DEPEND=">=dev-lang/go-1.2:="
+RDEPEND="!dev-db/etcdctl"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_prepare() {
+ sed -e "s|-ldflags '-s'|-x|" \
+ -i build || die
+}
+
+src_compile() {
+ ./build || die
+}
+
+src_install() {
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/*
+ dodoc README.md
+ use doc && dodoc -r Documentation
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ dodir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 755 /var/lib/${PN}
+ dodir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+}
+
+src_test() {
+ local x
+ for x in bin/*; do
+ ebegin "running ${x##*/} --help"
+ ${x} --help >/dev/null || die "${x##*/} --help failed"
+ eend
+ done
+}