summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-06-08 17:04:27 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-06-08 17:04:27 +0000
commitcbdf8ebb876bf9289479c963fc609e81a9f7e352 (patch)
treea0c3af6e06cde98bc807888e0d4b95f04f62b3cc /dev-db
parentVersion bump pypy to 1.9. (diff)
downloadgentoo-2-cbdf8ebb876bf9289479c963fc609e81a9f7e352.tar.gz
gentoo-2-cbdf8ebb876bf9289479c963fc609e81a9f7e352.tar.bz2
gentoo-2-cbdf8ebb876bf9289479c963fc609e81a9f7e352.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phppgadmin/ChangeLog10
-rw-r--r--dev-db/phppgadmin/phppgadmin-5.0.4.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-db/phppgadmin/ChangeLog b/dev-db/phppgadmin/ChangeLog
index 649a0d1d5d62..a844e79bd27e 100644
--- a/dev-db/phppgadmin/ChangeLog
+++ b/dev-db/phppgadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/phppgadmin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.102 2011/10/09 21:24:48 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/ChangeLog,v 1.103 2012/06/08 17:04:26 titanofold Exp $
+
+*phppgadmin-5.0.4 (08 Jun 2012)
+
+ 08 Jun 2012; Aaron W. Swenson <titanofold@gentoo.org>
+ +phppgadmin-5.0.4.ebuild:
+ Version bump.
09 Oct 2011; Tim Harder <radhermit@gentoo.org> -phppgadmin-4.2.2.ebuild,
-phppgadmin-4.2.3.ebuild, -phppgadmin-5.0.2.ebuild:
diff --git a/dev-db/phppgadmin/phppgadmin-5.0.4.ebuild b/dev-db/phppgadmin/phppgadmin-5.0.4.ebuild
new file mode 100644
index 000000000000..26be3a58a0aa
--- /dev/null
+++ b/dev-db/phppgadmin/phppgadmin-5.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phppgadmin/phppgadmin-5.0.4.ebuild,v 1.1 2012/06/08 17:04:27 titanofold Exp $
+
+EAPI="4"
+
+inherit webapp
+
+MY_P="phpPgAdmin-${PV}"
+
+DESCRIPTION="Web-based administration for Postgres database in php"
+HOMEPAGE="http://phppgadmin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[postgres,session]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ local doc
+ local docs="CREDITS DEVELOPERS FAQ HISTORY INSTALL TODO TRANSLATORS"
+ dodoc ${docs}
+ mv conf/config.inc.php-dist conf/config.inc.php
+
+ cp -r * "${D}"${MY_HTDOCSDIR}
+ for doc in ${docs} INSTALL LICENSE; do
+ rm -f "${D}"${MY_HTDOCSDIR}/${doc}
+ done
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf/config.inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}