summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-04-18 00:30:53 +0000
committerDonny Davies <woodchip@gentoo.org>2002-04-18 00:30:53 +0000
commit7eea407aba4b03a3324022ef994b5f09cd84a14d (patch)
tree6363b959d9cc1e1e1e003ffa28c1e842a567b112 /dev-db
parentadding spell support (diff)
downloadgentoo-2-7eea407aba4b03a3324022ef994b5f09cd84a14d.tar.gz
gentoo-2-7eea407aba4b03a3324022ef994b5f09cd84a14d.tar.bz2
gentoo-2-7eea407aba4b03a3324022ef994b5f09cd84a14d.zip
made a package for mysqltool
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysqltool/ChangeLog10
-rw-r--r--dev-db/mysqltool/files/digest-mysqltool-0.951
-rw-r--r--dev-db/mysqltool/mysqltool-0.95.ebuild52
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-db/mysqltool/ChangeLog b/dev-db/mysqltool/ChangeLog
new file mode 100644
index 000000000000..c7886b10841e
--- /dev/null
+++ b/dev-db/mysqltool/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/mysqltool
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/ChangeLog,v 1.1 2002/04/18 00:30:53 woodchip Exp $
+
+*mysqltool-0.95 (17 Apr 2002)
+
+ 17 Apr 2002; Donny Davies <woodchip@gentoo.org> :
+
+ Created an ebuild for mysqltool, a perl-based frontend for administering
+ MySQL servers. Similiar to phpMyAdmin.
diff --git a/dev-db/mysqltool/files/digest-mysqltool-0.95 b/dev-db/mysqltool/files/digest-mysqltool-0.95
new file mode 100644
index 000000000000..e506852425e2
--- /dev/null
+++ b/dev-db/mysqltool/files/digest-mysqltool-0.95
@@ -0,0 +1 @@
+MD5 9650d62eec7dab21d39c83d30f79a08b MysqlTool-0.95.tar.gz 44898
diff --git a/dev-db/mysqltool/mysqltool-0.95.ebuild b/dev-db/mysqltool/mysqltool-0.95.ebuild
new file mode 100644
index 000000000000..6a8ea569f28d
--- /dev/null
+++ b/dev-db/mysqltool/mysqltool-0.95.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95.ebuild,v 1.1 2002/04/18 00:30:53 woodchip Exp $
+
+S=${WORKDIR}/MysqlTool-${PV}
+DESCRIPTION="Web interface for managing one or more mysql server installations"
+SRC_URI="http://www.dajoba.com/projects/mysqltool/MysqlTool-${PV}.tar.gz"
+HOMEPAGE="http://www.dajoba.com/projects/mysqltool/"
+
+DEPEND="virtual/glibc sys-devel/perl"
+RDEPEND="${DEPEND} >=net-www/apache-1.3.24-r1 >=dev-db/mysql-3.23.38
+ dev-perl/CGI dev-perl/DBI dev-perl/DBD-mysql dev-perl/Crypt-Blowfish"
+
+src_compile() {
+ perl Makefile.PL || die
+ make || die
+ make test || die
+}
+
+src_install() {
+ eval `perl '-V:installarchlib'`
+ mkdir -p ${D}/$installarchlib
+
+ perl Makefile.PL
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc COPYING Changes MANIFEST README Upgrade
+
+ # the cgi and images..
+ dodir /home/httpd/htdocs/mysqltool
+ cp -a htdocs/* ${D}/home/httpd/htdocs/mysqltool
+ rm ${D}/home/httpd/htdocs/mysqltool/mysqltool.conf
+
+ # the config file..
+ insinto /etc/apache/conf/addon-modules
+ doins htdocs/mysqltool.conf
+ fowners apache.apache /etc/apache/conf/addon-modules/mysqltool.conf
+ fperms 0600 /etc/apache/conf/addon-modules/mysqltool.conf
+
+ # now fix its location in the main cgi..
+ cp ${D}/home/httpd/htdocs/mysqltool/index.cgi \
+ ${D}/home/httpd/htdocs/mysqltool/index.cgi.orig
+ sed -e "s:^\(require\).*:\1 '/etc/apache/conf/addon-modules/mysqltool.conf';:" \
+ ${D}/home/httpd/htdocs/mysqltool/index.cgi.orig > \
+ ${D}/home/httpd/htdocs/mysqltool/index.cgi
+ rm ${D}/home/httpd/htdocs/mysqltool/index.cgi.orig
+}