summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-12-17 19:05:32 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-12-17 19:05:32 +0000
commit78dc103fac0be9c716ef29e31cc0c53b7ee24261 (patch)
tree590a10324e8f4e03613a2376ca713b7a2d4fe25c /dev-db
parentamd64 stable (diff)
downloadgentoo-2-78dc103fac0be9c716ef29e31cc0c53b7ee24261.tar.gz
gentoo-2-78dc103fac0be9c716ef29e31cc0c53b7ee24261.tar.bz2
gentoo-2-78dc103fac0be9c716ef29e31cc0c53b7ee24261.zip
Version bump. Fixes bug #194806. Thanks to Arfrever Frehtes Taifersar Arahesis <Arfrever.FTA@GMail.Com>. Now uses EAPI 1 for default use flag values so change the nothreadsafe use flag to threadsafe.
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.5.43
-rw-r--r--dev-db/sqlite/sqlite-3.5.4.ebuild91
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-db/sqlite/files/digest-sqlite-3.5.4 b/dev-db/sqlite/files/digest-sqlite-3.5.4
new file mode 100644
index 000000000000..afac75dfaeee
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-3.5.4
@@ -0,0 +1,3 @@
+MD5 f17da840eed792e896c3408d0ce97718 sqlite-3.5.4.tar.gz 2092372
+RMD160 d11b535676e6d54c0d03adcb74c7dbfa1f12c064 sqlite-3.5.4.tar.gz 2092372
+SHA256 47daba209bd3bcffa1c5fcd5fdfc4f524eae619b4fa855aeeb1bbbc8bd2bb04f sqlite-3.5.4.tar.gz 2092372
diff --git a/dev-db/sqlite/sqlite-3.5.4.ebuild b/dev-db/sqlite/sqlite-3.5.4.ebuild
new file mode 100644
index 000000000000..2d5420fce295
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.5.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.5.4.ebuild,v 1.1 2007/12/17 19:05:32 betelgeuse Exp $
+
+EAPI="1"
+
+inherit alternatives eutils flag-o-matic libtool
+
+DESCRIPTION="an SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc soundex tcl +threadsafe"
+RESTRICT="!tcl? ( test )"
+
+DEPEND="doc? ( dev-lang/tcl )
+ tcl? ( dev-lang/tcl )"
+RDEPEND="tcl? ( dev-lang/tcl )"
+
+SOURCE="/usr/bin/lemon"
+ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+
+src_unpack() {
+ # test
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the test"
+ ewarn "suite."
+ eerror "Testsuite will not be run."
+ fi
+ fi
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/sandbox-fix2.patch
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # not available via configure and requested in bug #143794
+ use soundex && append-flags -DSQLITE_SOUNDEX=1
+
+ econf ${myconf} \
+ $(use_enable debug) \
+ $(use_enable threadsafe) \
+ $(use_enable threadsafe cross-thread-connections) \
+ $(use_enable tcl)
+
+ emake all || die "emake all failed"
+
+ if use doc ; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_test() {
+ if use tcl ; then
+ if has userpriv ${FEATURES} ; then
+ if use debug ; then
+ emake fulltest || die "some test failed"
+ else
+ emake test || die "some test failed"
+ fi
+ fi
+ fi
+}
+
+src_install () {
+ emake \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)" \
+ install \
+ || die "make install failed"
+
+ newbin lemon lemon-${SLOT} || die
+
+ dodoc README VERSION || die
+ doman sqlite3.1 || die
+
+ use doc && dohtml doc/* art/*.gif
+}