summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:12:02 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:12:02 +0000
commit216d0781fb7cd32564e158e856bf0cb0166f1be4 (patch)
tree408bd5fe44f59602a3d1789faf64a377b27ab34a /dev-db
parentremoved redundantly WANT_* (diff)
downloadgentoo-2-216d0781fb7cd32564e158e856bf0cb0166f1be4.tar.gz
gentoo-2-216d0781fb7cd32564e158e856bf0cb0166f1be4.tar.bz2
gentoo-2-216d0781fb7cd32564e158e856bf0cb0166f1be4.zip
initial commit
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/ChangeLog11
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch35
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild64
-rw-r--r--dev-db/lib_mysqludf_fPROJ4/metadata.xml9
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_fPROJ4/ChangeLog b/dev-db/lib_mysqludf_fPROJ4/ChangeLog
new file mode 100644
index 000000000000..03bb45a27ac4
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-db/lib_mysqludf_fPROJ4
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_fPROJ4/ChangeLog,v 1.1 2011/10/19 12:12:02 sbriesen Exp $
+
+*lib_mysqludf_fPROJ4-0.1.0 (19 Oct 2011)
+
+ 19 Oct 2011; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/lib_mysqludf_fPROJ4-warnings.patch, +lib_mysqludf_fPROJ4-0.1.0.ebuild,
+ +metadata.xml:
+ initial commit
+
diff --git a/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch b/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch
new file mode 100644
index 000000000000..0b9669991cb3
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/files/lib_mysqludf_fPROJ4-warnings.patch
@@ -0,0 +1,35 @@
+--- lib_mysqludf_fPROJ4.c.orig 2010-05-09 13:46:12.000000000 +0200
++++ lib_mysqludf_fPROJ4.c 2011-10-19 02:32:48.000000000 +0200
+@@ -1,5 +1,3 @@
+-/*
+-
+ /*
+ lib_mysqludf_fPROJ4 - An extended set of scientific functions which
+ converts geographic longitude and latitude coordinates into cartesian
+@@ -178,7 +176,7 @@
+ }
+ double fPROJ4_transform(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
+ {
+- projPJ pj_in, pj_out;
++ projPJ pj_in=NULL, pj_out=NULL;
+ double x, y,z;
+ int p,t;
+
+@@ -248,7 +246,7 @@
+ }
+ double fPROJ4_Geo2UTM(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
+ {
+- projPJ pj_in, pj_out;
++ projPJ pj_in=NULL, pj_out=NULL;
+ double x, y;
+ int p,t,zone;
+ char *tmp;
+@@ -323,7 +321,7 @@
+ }
+ double fPROJ4_UTM2Geo(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
+ {
+- projPJ pj_in, pj_out;
++ projPJ pj_in=NULL, pj_out=NULL;
+ double x, y;
+ int p,t,zone;
+ char *tmp;
diff --git a/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild b/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild
new file mode 100644
index 000000000000..a124dc188004
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_fPROJ4/lib_mysqludf_fPROJ4-0.1.0.ebuild,v 1.1 2011/10/19 12:12:02 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MySQL UDFs which converts geographic/cartesian coordinates"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_fPROJ4/"
+SRC_URI="http://www.mysqludf.org/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1
+ sci-libs/proj"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+# compile helper
+_compile() {
+ local CC="$(tc-getCC)"
+ echo "${CC} ${@}" && "${CC}" "${@}"
+}
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-warnings.patch"
+
+ # fix doc (BOM, CR/LF, soname)
+ sed -i -e '1 s|^\xEF\xBB\xBF||' \
+ -e "s|'\(${PN}\).*'|'\1.so'|g" ${PN}.sql
+ echo >> ${PN}.sql # add LF
+ edos2unix ${PN}.sql
+}
+
+src_compile() {
+ _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} -lproj \
+ -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
+}
+
+src_install() {
+ exeinto "${MYSQL_PLUGINDIR}"
+ doexe ${PN}.so
+ dodoc ${PN}.sql
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_fPROJ4/metadata.xml b/dev-db/lib_mysqludf_fPROJ4/metadata.xml
new file mode 100644
index 000000000000..abc550987baf
--- /dev/null
+++ b/dev-db/lib_mysqludf_fPROJ4/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+</pkgmetadata>