summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-07-11 11:27:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-07-11 11:27:52 +0000
commit194de5e1a19ccf2f03d791af18a45ab69a10d73a (patch)
tree04ead9864f73a46399d0a8c00a989e0da2557d34 /dev-db
parentDrop hppa keyword per bug #324511. (diff)
downloadgentoo-2-194de5e1a19ccf2f03d791af18a45ab69a10d73a.tar.gz
gentoo-2-194de5e1a19ccf2f03d791af18a45ab69a10d73a.tar.bz2
gentoo-2-194de5e1a19ccf2f03d791af18a45ab69a10d73a.zip
Bump for #327671, thanks to Johan Bergstroem
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/kyotocabinet/ChangeLog8
-rw-r--r--dev-db/kyotocabinet/files/remove_ldconfig-1.0.4.patch12
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.0.4.ebuild48
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index d7e128ac2176..baa1da63c4e0 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.1 2010/06/17 17:32:12 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.2 2010/07/11 11:27:52 patrick Exp $
+
+*kyotocabinet-1.0.4 (11 Jul 2010)
+
+ 11 Jul 2010; Patrick Lauer <patrick@gentoo.org>
+ +kyotocabinet-1.0.4.ebuild, +files/remove_ldconfig-1.0.4.patch:
+ Bump for #327671, thanks to Johan Bergstroem
*kyotocabinet-1.0.2 (17 Jun 2010)
diff --git a/dev-db/kyotocabinet/files/remove_ldconfig-1.0.4.patch b/dev-db/kyotocabinet/files/remove_ldconfig-1.0.4.patch
new file mode 100644
index 000000000000..8bd7a8645290
--- /dev/null
+++ b/dev-db/kyotocabinet/files/remove_ldconfig-1.0.4.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.in b/Makefile.in
+index 59e71a0..bd42c67 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -123,7 +123,6 @@ install :
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- -[ "$$UID" = 0 ] && PATH=/sbin:/usr/sbin:$(PATH) ldconfig || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Kyoto Cabinet.\n'
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.0.4.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.0.4.ebuild
new file mode 100644
index 000000000000..fdd717270267
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.0.4.ebuild,v 1.1 2010/07/11 11:27:52 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://1978th.net/kyotocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/remove_ldconfig-${PV}.patch"
+ epatch "${FILESDIR}/remove_docinst.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}