summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-09-11 06:56:03 +0000
committerPeter Volkov <pva@gentoo.org>2008-09-11 06:56:03 +0000
commit1aaeab1d2ce3f5086cfc626ff16a2417497d1e42 (patch)
treee2dc7a62f3c34bef396bb864145f9512ad52641e /dev-db/xindice
parentrevbump for more udev fixes (diff)
downloadgentoo-2-1aaeab1d2ce3f5086cfc626ff16a2417497d1e42.tar.gz
gentoo-2-1aaeab1d2ce3f5086cfc626ff16a2417497d1e42.tar.bz2
gentoo-2-1aaeab1d2ce3f5086cfc626ff16a2417497d1e42.zip
enewuser/enewgroup die on their own, no need to || die. Fixed quotation.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 i686)
Diffstat (limited to 'dev-db/xindice')
-rw-r--r--dev-db/xindice/ChangeLog7
-rw-r--r--dev-db/xindice/xindice-1.0-r4.ebuild24
2 files changed, 17 insertions, 14 deletions
diff --git a/dev-db/xindice/ChangeLog b/dev-db/xindice/ChangeLog
index 5072eb8ff4ac..da856e962845 100644
--- a/dev-db/xindice/ChangeLog
+++ b/dev-db/xindice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/xindice
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/ChangeLog,v 1.15 2007/04/09 11:36:15 betelgeuse Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/ChangeLog,v 1.16 2008/09/11 06:56:03 pva Exp $
+
+ 11 Sep 2008; Peter Volkov <pva@gentoo.org> xindice-1.0-r4.ebuild:
+ enewuser/enewgroup die on their own, no need to || die. Fixed quotation.
09 Apr 2007; Petteri Räty <betelgeuse@gentoo.org> -xindice-1.0-r3.ebuild:
Remove old version.
diff --git a/dev-db/xindice/xindice-1.0-r4.ebuild b/dev-db/xindice/xindice-1.0-r4.ebuild
index 55a20ad6d876..47b8750a2116 100644
--- a/dev-db/xindice/xindice-1.0-r4.ebuild
+++ b/dev-db/xindice/xindice-1.0-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/xindice-1.0-r4.ebuild,v 1.4 2007/04/09 11:35:09 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/xindice/xindice-1.0-r4.ebuild,v 1.5 2008/09/11 06:56:03 pva Exp $
inherit eutils java-pkg-2 java-ant-2
@@ -21,16 +21,16 @@ RDEPEND="|| ( =virtual/jre-1.4* =virtual/jre-1.3* )"
S=${WORKDIR}/xml-${P}
pkg_setup() {
- enewgroup ${PN} || die "Adding group ${PN} failed"
- enewuser ${PN} -1 /bin/sh /var/run/${PN} ${PN} || die "Adding user ${PN} failed"
+ enewgroup ${PN}
+ enewuser ${PN} -1 /bin/sh /var/run/${PN} ${PN}
java-pkg-2_pkg_setup
}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-r3.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-r3.patch
}
src_compile() {
@@ -41,19 +41,19 @@ src_compile() {
src_install() {
export TARGET=/opt/${PN}
keepdir /var/run/${PN}
- chown ${PN}:${PN} ${D}/var/run/${PN}
+ chown ${PN}:${PN} "${D}"/var/run/${PN}
dodir ${TARGET}
dodir ${TARGET}/java
- cp -pPR bin config icons docs logs idl ${D}${TARGET}
+ cp -pPR bin config icons docs logs idl "${D}"${TARGET}
cd java
- cp -pPR lib tests examples ${D}${TARGET}/java
+ cp -pPR lib tests examples "${D}"${TARGET}/java
cd ..
dodoc docs/LICENSE docs/README docs/FAQ docs/TODO docs/VERSIONS docs/AUTHORS
dohtml docs/AdministratorsGuide.html docs/DevelopersGuide.html docs/UsersGuide.html docs/ToolsReference.html docs/feather.gif docs/index.html docs/xindice.jpg
- doenvd ${FILESDIR}/21${PN}
- newinitd ${FILESDIR}/${PN}-r2 ${PN}
+ doenvd "${FILESDIR}"/21${PN}
+ newinitd "${FILESDIR}"/${PN}-r2 ${PN}
insinto ${TARGET}
doins start
keepdir /opt/${PN}/db
- chown -R ${PN}:${PN} ${D}/opt/${PN}
+ chown -R ${PN}:${PN} "${D}"/opt/${PN}
}