summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-23 04:23:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-23 04:23:59 +0000
commit71c8482324e93787912e380fc88e8645878fc75f (patch)
tree33931d347e4e0212980cd315517c0c97883af0dd /dev-db/tokyocabinet
parentadded prefix support (bug #388791) (diff)
downloadgentoo-2-71c8482324e93787912e380fc88e8645878fc75f.tar.gz
gentoo-2-71c8482324e93787912e380fc88e8645878fc75f.tar.bz2
gentoo-2-71c8482324e93787912e380fc88e8645878fc75f.zip
Bump
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/tokyocabinet')
-rw-r--r--dev-db/tokyocabinet/ChangeLog8
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild56
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index 2ef882740318..aff442f8514f 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.42 2012/04/25 16:22:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.43 2012/08/23 04:23:59 patrick Exp $
+
+*tokyocabinet-1.4.48 (23 Aug 2012)
+
+ 23 Aug 2012; Patrick Lauer <patrick@gentoo.org> +tokyocabinet-1.4.48.ebuild:
+ Bump
25 Apr 2012; Justin Lecher <jlec@gentoo.org> tokyocabinet-1.4.47.ebuild:
Drop unnessecary die
@@ -184,4 +189,3 @@
+tokyocabinet-1.4.34-r1.ebuild, +files/fix_rpath.patch, +metadata.xml:
Initial import of tokyocabinet. Thanks to Petteri Räty, Mark Lewandowski
and Johan Bergstroem for the ebuild. Fixes #240696
-
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild
new file mode 100644
index 000000000000..b7af65c2d2b5
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.48.ebuild,v 1.1 2012/08/23 04:23:59 patrick Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://fallabs.com/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ sed -i \
+ -e "/ldconfig/d" \
+ -e "/DATADIR/d" Makefile.in || die
+ # cflags fix - remove -O2 at end of line and -fomit-frame-pointer
+ sed -i -e 's/-O3"$/"/' configure.in || die
+ sed -i -e 's/-fomit-frame-pointer//' configure.in || die
+ # flag only works on x86 derivatives, remove everywhere else
+ if ! use x86 && ! use amd64; then sed -i -e 's/ -minline-all-stringops//' configure.in; fi
+ eautoreconf
+}
+
+src_configure() {
+ # we use the "fastest" target without the -O3
+ econf $(use_enable debug) --enable-off64 --enable-fastest
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}