summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-04-11 18:59:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-04-11 18:59:29 +0000
commit4a580f5e251f0563e0f3b027eb41046d6b3626cf (patch)
tree1111ad78341148d9f8ab71676a8be71d740b88f2 /dev-db/sqsh/sqsh-2.1.3-r1.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-4a580f5e251f0563e0f3b027eb41046d6b3626cf.tar.gz
gentoo-2-4a580f5e251f0563e0f3b027eb41046d6b3626cf.tar.bz2
gentoo-2-4a580f5e251f0563e0f3b027eb41046d6b3626cf.zip
Added patches from the new maintainer-by-proxy Richard Brown <mynamewasgone@gmail.com> in bug #88343. These patches make the build system a little saner, by recognising the difference between --with and --without for motif. Additionally, he did a nice patch to make it obey mandir like every other good package, and specify that the rc file goes into sysconfdir, like every other good package.
(Portage version: 1.585-cvs)
Diffstat (limited to 'dev-db/sqsh/sqsh-2.1.3-r1.ebuild')
-rw-r--r--dev-db/sqsh/sqsh-2.1.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-db/sqsh/sqsh-2.1.3-r1.ebuild b/dev-db/sqsh/sqsh-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..332d61a58699
--- /dev/null
+++ b/dev-db/sqsh/sqsh-2.1.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqsh/sqsh-2.1.3-r1.ebuild,v 1.1 2005/04/11 18:59:29 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="Replacement for the venerable 'isql' program supplied by Sybase."
+HOMEPAGE="http://sourceforge.net/projects/sqsh/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-autotools.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="readline X motif"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="dev-db/freetds
+ readline? ( sys-libs/readline )
+ X? ( virtual/x11 )
+ motif? ( x11-libs/openmotif )
+ virtual/libc"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${WORKDIR}/${P}-autotools.patch
+}
+
+src_compile() {
+ export SYBASE=/usr
+
+ local myconf
+
+ econf \
+ $(use_with readline) \
+ $(use_with X x) \
+ $(use_with motif) \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ einstall install.man || die
+
+ dodoc INSTALL README doc/*
+}