summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-04-21 09:11:00 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-04-21 09:11:00 +0000
commit14cbd29bc1b91912a01273372f0714e0ede801cf (patch)
treed8f433797ba4da4487c9a169168fd5d01f7e3dd4 /dev-db/sqlcipher
parentDrop old (diff)
downloadgentoo-2-14cbd29bc1b91912a01273372f0714e0ede801cf.tar.gz
gentoo-2-14cbd29bc1b91912a01273372f0714e0ede801cf.tar.bz2
gentoo-2-14cbd29bc1b91912a01273372f0714e0ede801cf.zip
Initial commit of SQLCipher
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'dev-db/sqlcipher')
-rw-r--r--dev-db/sqlcipher/ChangeLog10
-rw-r--r--dev-db/sqlcipher/metadata.xml8
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.3.0.ebuild41
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/ChangeLog b/dev-db/sqlcipher/ChangeLog
new file mode 100644
index 000000000000..0bb0c1de3ce8
--- /dev/null
+++ b/dev-db/sqlcipher/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-db/sqlcipher
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlcipher/ChangeLog,v 1.1 2015/04/21 09:11:00 pinkbyte Exp $
+
+*sqlcipher-3.3.0 (21 Apr 2015)
+
+ 21 Apr 2015; Sergey Popov <pinkbyte@gentoo.org> +sqlcipher-3.3.0.ebuild,
+ +metadata.xml:
+ Initial commit of SQLCipher
+
diff --git a/dev-db/sqlcipher/metadata.xml b/dev-db/sqlcipher/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/dev-db/sqlcipher/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild b/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild
new file mode 100644
index 000000000000..0ac5d393760b
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild,v 1.1 2015/04/21 09:11:00 pinkbyte Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib flag-o-matic
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="http://sqlcipher.net/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="readline static-libs tcl"
+
+# Tcl is always needed by buildsystem
+RDEPEND="dev-libs/openssl:0[${MULTILIB_USEDEP}]
+ readline? ( sys-libs/readline:0[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-lang/tcl"
+
+src_prepare() {
+ append-cflags -DSQLITE_HAS_CODEC
+
+ autotools-multilib_src_prepare
+}
+
+src_configure()
+{
+ local myeconfargs=(
+ --enable-tempstore=yes
+ $(use_enable readline)
+ $(use_enable tcl)
+ )
+ autotools-multilib_src_configure
+}