summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2013-03-08 15:34:03 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2013-03-08 15:34:03 +0000
commite63f660074be4cc7eb1c94510ed05ebe5e27dbfd (patch)
tree60cfed3b33bc68e5f2c45e1f78fb1a2ed7bf3b66 /dev-db/oracle-instantclient-sqlplus
parentBump. (diff)
downloadgentoo-2-e63f660074be4cc7eb1c94510ed05ebe5e27dbfd.tar.gz
gentoo-2-e63f660074be4cc7eb1c94510ed05ebe5e27dbfd.tar.bz2
gentoo-2-e63f660074be4cc7eb1c94510ed05ebe5e27dbfd.zip
sqlplus binary needs pax-mark for hardened, bug#456694. Credits to Hugo Mildenberger at web.de.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'dev-db/oracle-instantclient-sqlplus')
-rw-r--r--dev-db/oracle-instantclient-sqlplus/ChangeLog11
-rw-r--r--dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild72
2 files changed, 81 insertions, 2 deletions
diff --git a/dev-db/oracle-instantclient-sqlplus/ChangeLog b/dev-db/oracle-instantclient-sqlplus/ChangeLog
index 0fe29c6b6db3..7ff17deea9f0 100644
--- a/dev-db/oracle-instantclient-sqlplus/ChangeLog
+++ b/dev-db/oracle-instantclient-sqlplus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/oracle-instantclient-sqlplus
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.35 2012/11/15 19:47:11 haubi Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.36 2013/03/08 15:34:03 haubi Exp $
+
+*oracle-instantclient-sqlplus-11.2.0.3-r1 (08 Mar 2013)
+
+ 08 Mar 2013; Michael Haubenwallner <haubi@gentoo.org>
+ +oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild:
+ sqlplus binary needs pax-mark for hardened, bug#456694.
+ Credits to Hugo Mildenberger at web.de.
15 Nov 2012; Michael Haubenwallner <haubi@gentoo.org>
oracle-instantclient-sqlplus-11.2.0.3.ebuild:
diff --git a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild
new file mode 100644
index 000000000000..8deac233c8f6
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild,v 1.1 2013/03/08 15:34:03 haubi Exp $
+
+EAPI="4"
+
+inherit eutils multilib pax-utils
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN#oracle-}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN#oracle-}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: SQL*Plus"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+ x86? ( ${MY_A_x86} )
+ amd64? ( ${MY_A_amd64} )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"/instantclient_11_2
+
+QA_PREBUILT="
+ usr/lib*/oracle/${PV}/client/lib*/lib*
+ usr/lib*/oracle/${PV}/client/bin/sqlplus
+"
+
+my_arch() {
+ # platform name
+ MY_PLAT=MY_PLAT_${ARCH}
+ export MY_PLAT=${!MY_PLAT}
+ # distfile
+ MY_A=MY_A_${ARCH}
+ export MY_A=${!MY_A}
+}
+
+pkg_nofetch() {
+ my_arch
+ eerror "Please go to"
+ eerror " ${HOMEPAGE%/*}/index-097480.html"
+ eerror " and download"
+ eerror "Instant Client for ${MY_PLAT}"
+ eerror " SQL*Plus: ${MY_A}"
+ eerror "After downloading, put it in:"
+ eerror " ${DISTDIR}/"
+}
+
+src_install() {
+ # all binaries go here
+ local oracle_home=usr/$(get_libdir)/oracle/${PV}/client
+ into /"${oracle_home}"
+
+ dolib.so libsqlplus$(get_libname) libsqlplusic$(get_libname)
+ dobin sqlplus
+
+ insinto /"${oracle_home}"/sqlplus/admin
+ doins glogin.sql
+
+ pax-mark -c "${ED}${oracle_home}"/bin/sqlplus || die
+
+ dosym /"${oracle_home}"/bin/sqlplus /usr/bin/sqlplus
+}