summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-14 13:42:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-14 13:42:45 +0000
commit75a09b0908d7e1cb0102eecaf922793a84f0dcca (patch)
treea7b947b1e36eb625e119a14e732460ea82de0297 /dev-db/metakit/files
parentstable x86, bug 325639 (diff)
downloadgentoo-2-75a09b0908d7e1cb0102eecaf922793a84f0dcca.tar.gz
gentoo-2-75a09b0908d7e1cb0102eecaf922793a84f0dcca.tar.bz2
gentoo-2-75a09b0908d7e1cb0102eecaf922793a84f0dcca.zip
Delete unused patch.
Diffstat (limited to 'dev-db/metakit/files')
-rw-r--r--dev-db/metakit/files/metakit-2.4.9.3-64bit.patch40
-rw-r--r--dev-db/metakit/files/metakit-2.4.9.7-LDFLAGS.patch31
2 files changed, 31 insertions, 40 deletions
diff --git a/dev-db/metakit/files/metakit-2.4.9.3-64bit.patch b/dev-db/metakit/files/metakit-2.4.9.3-64bit.patch
deleted file mode 100644
index 5b91a8995cf3..000000000000
--- a/dev-db/metakit/files/metakit-2.4.9.3-64bit.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -Nur metakit-2.4.9.3-orig/python/PyRowRef.cpp metakit-2.4.9.3/python/PyRowRef.cpp
---- metakit-2.4.9.3-orig/python/PyRowRef.cpp 2004-01-20 17:46:06.000000000 -0800
-+++ metakit-2.4.9.3/python/PyRowRef.cpp 2006-07-03 23:40:57.000000000 -0700
-@@ -24,12 +24,12 @@
- }
-
- static int PyRowRef_print(PyRowRef *o, FILE *f, int) {
-- fprintf(f, "<PyRowRef object at %x>", (int)o);
-+ fprintf(f, "<PyRowRef object at %p>", (long)o);
- return 0;
- }
-
- static int PyRORowRef_print(PyRowRef *o, FILE *f, int) {
-- fprintf(f, "<PyRORowRef object at %x>", (int)o);
-+ fprintf(f, "<PyRORowRef object at %p>", (long)o);
- return 0;
- }
-
-diff -Nur metakit-2.4.9.3-orig/python/PyView.cpp metakit-2.4.9.3/python/PyView.cpp
---- metakit-2.4.9.3-orig/python/PyView.cpp 2004-01-20 17:46:06.000000000 -0800
-+++ metakit-2.4.9.3/python/PyView.cpp 2006-07-03 23:40:57.000000000 -0700
-@@ -971,15 +971,15 @@
- }
-
- static int PyView_print(PyView *o, FILE *f, int) {
-- fprintf(f, "<PyView object at %x>", (int)o);
-+ fprintf(f, "<PyView object at %p", (long)o);
- return 0;
- }
- static int PyViewer_print(PyView *o, FILE *f, int) {
-- fprintf(f, "<PyViewer object at %x>", (int)o);
-+ fprintf(f, "<PyViewer object at %p>", (long)o);
- return 0;
- }
- static int PyROViewer_print(PyView *o, FILE *f, int) {
-- fprintf(f, "<PyROViewer object at %x>", (int)o);
-+ fprintf(f, "<PyROViewer object at %p>", (long)o);
- return 0;
- }
-
diff --git a/dev-db/metakit/files/metakit-2.4.9.7-LDFLAGS.patch b/dev-db/metakit/files/metakit-2.4.9.7-LDFLAGS.patch
new file mode 100644
index 000000000000..210e42939717
--- /dev/null
+++ b/dev-db/metakit/files/metakit-2.4.9.7-LDFLAGS.patch
@@ -0,0 +1,31 @@
+--- unix/Makefile.in
++++ unix/Makefile.in
+@@ -134,24 +134,24 @@
+ ranlib $@
+
+ libmk4$(SHLIB_SUFFIX): $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ Mk4tcl$(LIB_SUFFIX): mk4tcl.o mk4too.o $(LOBJS)
+ ar rcu $@ mk4tcl.o mk4too.o $(LOBJS)
+ ranlib $@
+
+ Mk4tcl$(SHLIB_SUFFIX): mk4tcl.o mk4too.o $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ mk4tcl.o mk4too.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ mk4tcl.o mk4too.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ Mk4py$(LIB_SUFFIX): $(PYOBJS) $(LOBJS)
+ ar cru $@ $(PYOBJS) $(LOBJS)
+ ranlib $@
+
+ Mk4py$(SHLIB_SUFFIX): $(PYOBJS) $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ $(PYOBJS) $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ $(PYOBJS) $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ Mk4lua$(SHLIB_SUFFIX): mk4lua.o $(LOBJS) $(LINK_SPECIAL_FILES)
+- $(SHLIB_LD) -o $@ mk4lua.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
++ $(SHLIB_LD) $(LDFLAGS) -o $@ mk4lua.o $(LOBJS) $(LINK_SPECIAL_FLAGS)
+
+ demo: $(srcdir)/../demos/demo.cpp libmk4$(LIBEXT)
+ $(CXX) $(CXX_SWITCHES) -o $@$(EXEEXT) \