summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-06-17 17:32:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-06-17 17:32:12 +0000
commitb3d93433a4319ad1530be25e04a7cc9e857ba067 (patch)
treed8ce87ba605214fc8b73642bbe2fb034283d286d /dev-db/kyotocabinet
parentFixed gcc-4.5 issue, bug #320107. (diff)
downloadgentoo-2-b3d93433a4319ad1530be25e04a7cc9e857ba067.tar.gz
gentoo-2-b3d93433a4319ad1530be25e04a7cc9e857ba067.tar.bz2
gentoo-2-b3d93433a4319ad1530be25e04a7cc9e857ba067.zip
Initial import. Ebuild by jbergstroem.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog11
-rw-r--r--dev-db/kyotocabinet/files/fix_rpath.patch61
-rw-r--r--dev-db/kyotocabinet/files/remove_docinst.patch13
-rw-r--r--dev-db/kyotocabinet/files/remove_ldconfig.patch12
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.0.2.ebuild48
-rw-r--r--dev-db/kyotocabinet/metadata.xml13
6 files changed, 158 insertions, 0 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
new file mode 100644
index 000000000000..d7e128ac2176
--- /dev/null
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-db/kyotocabinet
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.1 2010/06/17 17:32:12 patrick Exp $
+
+*kyotocabinet-1.0.2 (17 Jun 2010)
+
+ 17 Jun 2010; Patrick Lauer <patrick@gentoo.org>
+ +kyotocabinet-1.0.2.ebuild, +files/fix_rpath.patch,
+ +files/remove_docinst.patch, +files/remove_ldconfig.patch, +metadata.xml:
+ Initial import. Ebuild by jbergstroem.
+
diff --git a/dev-db/kyotocabinet/files/fix_rpath.patch b/dev-db/kyotocabinet/files/fix_rpath.patch
new file mode 100644
index 000000000000..a6a79384e437
--- /dev/null
+++ b/dev-db/kyotocabinet/files/fix_rpath.patch
@@ -0,0 +1,61 @@
+diff --git a/Makefile.in b/Makefile.in
+index d2601ec..64c76c7 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -53,8 +53,8 @@ CXXFLAGS = @MYCXXFLAGS@
+ LDFLAGS = @MYLDFLAGS@
+ CMDLDFLAGS = @MYCMDLDFLAGS@
+ LIBS = @LIBS@
+-LDENV = LD_RUN_PATH=/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
+-RUNENV = @MYLDLIBPATHENV@=.:/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
++LDENV =
++RUNENV = @MYLDLIBPATHENV@=.:$(LIBDIR)
+ POSTCMD = @MYPOSTCMD@
+
+
+diff --git a/configure.in b/configure.in
+index 3ce09c1..ae00c62 100644
+--- a/configure.in
++++ b/configure.in
+@@ -32,27 +32,17 @@ MYDOCUMENTFILES="COPYING ChangeLog THANKS doc kyotocabinet.idl"
+ MYPCFILES="kyotocabinet.pc"
+
+ # Building flags
+-MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char -O2"
++MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char"
+ MYCXXFLAGS="-Wall -fPIC -fsigned-char -O2"
+-MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I$HOME/include -I/usr/local/include"
++MYCPPFLAGS="-I. -I\$(INCLUDEDIR)"
+ MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1"
+ MYCPPFLAGS="$MYCPPFLAGS -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D__EXTENSIONS__"
+-MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib"
++MYLDFLAGS="-L. -L\$(LIBDIR)"
+ MYCMDLDFLAGS=""
+ MYRUNPATH="\$(LIBDIR)"
+ MYLDLIBPATHENV="LD_LIBRARY_PATH"
+ MYPOSTCMD="true"
+
+-# Building paths
+-PATH="$PATH:$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin"
+-PATH="$PATH:/opt/SUNWspro/bin:/usr/ccs/bin:/usr/xpg4/bin:/usr/xpg6/bin:/usr/ucb"
+-CPATH="$HOME/include:/usr/local/include:$CPATH"
+-LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH"
+-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
+-PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
+-export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
+-
+-
+
+ #================================================================
+ # Options
+diff --git a/kyotocabinet.pc.in b/kyotocabinet.pc.in
+index d9b67f1..8ede1a9 100644
+--- a/kyotocabinet.pc.in
++++ b/kyotocabinet.pc.in
+@@ -10,5 +10,5 @@ datadir=@datadir@
+ Name: Kyoto Cabinet
+ Description: another modern implementation of DBM
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -ltokyocabinet @LIBS@
++Libs: -L${libdir} -ltokyocabinet
+ Cflags: -I${includedir}
diff --git a/dev-db/kyotocabinet/files/remove_docinst.patch b/dev-db/kyotocabinet/files/remove_docinst.patch
new file mode 100644
index 000000000000..d04c7b362a33
--- /dev/null
+++ b/dev-db/kyotocabinet/files/remove_docinst.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index a813215..eefa4eb 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -117,8 +117,6 @@ install :
+ cp -Rf $(LIBRARYFILES) $(DESTDIR)$(LIBDIR)
+ mkdir -p $(DESTDIR)$(BINDIR)
+ cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
+- mkdir -p $(DESTDIR)$(DATADIR)
+- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DATADIR)
+ mkdir -p $(DESTDIR)$(MAN1DIR)
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
diff --git a/dev-db/kyotocabinet/files/remove_ldconfig.patch b/dev-db/kyotocabinet/files/remove_ldconfig.patch
new file mode 100644
index 000000000000..f454c4729b59
--- /dev/null
+++ b/dev-db/kyotocabinet/files/remove_ldconfig.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.in b/Makefile.in
+index 64c76c7..a813215 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -123,7 +123,6 @@ install :
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- [ "$$UID" = 0 ] && ldconfig || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Kyoto Cabinet.\n'
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.0.2.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.0.2.ebuild
new file mode 100644
index 000000000000..1c5ed6b15f78
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.0.2.ebuild,v 1.1 2010/06/17 17:32:12 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://1978th.net/kyotocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/remove_ldconfig.patch"
+ epatch "${FILESDIR}/remove_docinst.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${P}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}
diff --git a/dev-db/kyotocabinet/metadata.xml b/dev-db/kyotocabinet/metadata.xml
new file mode 100644
index 000000000000..4cec73f2157e
--- /dev/null
+++ b/dev-db/kyotocabinet/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ </maintainer>
+</pkgmetadata>