summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-05-07 16:29:59 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-05-07 16:29:59 +0000
commit0978d35b01069a7cc1850d4f5e522150380f29e7 (patch)
tree144e650434553d9ba996c05c9781de8d609eb76d /dev-db/henplus
parentMigrate to split-ant. (diff)
downloadgentoo-2-0978d35b01069a7cc1850d4f5e522150380f29e7.tar.gz
gentoo-2-0978d35b01069a7cc1850d4f5e522150380f29e7.tar.bz2
gentoo-2-0978d35b01069a7cc1850d4f5e522150380f29e7.zip
Make the -pre file behave the same way as upstream wrapper script in populating CLASSPATH.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-db/henplus')
-rw-r--r--dev-db/henplus/ChangeLog9
-rw-r--r--dev-db/henplus/files/digest-henplus-0.9.7-r13
-rwxr-xr-xdev-db/henplus/files/henplus.pre23
-rw-r--r--dev-db/henplus/henplus-0.9.7-r1.ebuild48
4 files changed, 81 insertions, 2 deletions
diff --git a/dev-db/henplus/ChangeLog b/dev-db/henplus/ChangeLog
index 2c40fdc1ac94..9bec023d3f45 100644
--- a/dev-db/henplus/ChangeLog
+++ b/dev-db/henplus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/henplus
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.15 2007/04/26 23:06:41 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/ChangeLog,v 1.16 2007/05/07 16:29:59 betelgeuse Exp $
+
+*henplus-0.9.7-r1 (07 May 2007)
+
+ 07 May 2007; Petteri Räty <betelgeuse@gentoo.org> files/henplus.pre,
+ +henplus-0.9.7-r1.ebuild:
+ Make the -pre file behave the same way as upstream wrapper script in
+ populating CLASSPATH.
26 Apr 2007; Petteri Räty <betelgeuse@gentoo.org> henplus-0.9.7.ebuild:
inherit java-ant-2 to make JAVA_PKG_STRICT happy and stylistic cleanup.
diff --git a/dev-db/henplus/files/digest-henplus-0.9.7-r1 b/dev-db/henplus/files/digest-henplus-0.9.7-r1
new file mode 100644
index 000000000000..8a32ec6a3148
--- /dev/null
+++ b/dev-db/henplus/files/digest-henplus-0.9.7-r1
@@ -0,0 +1,3 @@
+MD5 9e20fad7e4042230cd54f2e49146572f henplus-0.9.7.tar.gz 219625
+RMD160 42c8067f8b0f205a34cb79bd053650debe9382e3 henplus-0.9.7.tar.gz 219625
+SHA256 9dff883c30c377a5e2c58928ad7442ed94710252df0f1d96fc509063839d33e7 henplus-0.9.7.tar.gz 219625
diff --git a/dev-db/henplus/files/henplus.pre b/dev-db/henplus/files/henplus.pre
index 59b20bc3f176..c29585e369fa 100755
--- a/dev-db/henplus/files/henplus.pre
+++ b/dev-db/henplus/files/henplus.pre
@@ -1,3 +1,24 @@
+#
+# Based on the upstream script but parts not relevant to Gentoo
+# stripped away. We would not need this at all but better to make
+# this behave as the upstream docs say and then also have all the
+# Gentoo goodies.
+# https://bugs.gentoo.org/show_bug.cgi?id=176185
+
+##------------------
+THISDIR=`dirname $0`
+# install layout is: script in /usr/bin/henplus and libs in /usr/share/henplus
+HENPLUSDIR=$THISDIR/../share/henplus
+
+# you may just throw your own jar files in this dir.
+# (like additional JDBC-drivers, that are not in default
+# classpath)
+for f in $HENPLUSDIR/*.jar $HENPLUSDIR/*.zip ; do
+ if [ -r "$f" ] ; then
+ CLASSPATH=$CLASSPATH:$f
+ fi
+done
+
# starting at the current directory we look for additional
# JDBC-drivers in .henplus/lib-directories up the path.
# if no directory like that has been found the one in the
@@ -8,7 +29,7 @@ CUSTOM_HENPLUSDIR=""
while [ $DIR != "/" ] ; do
if [ -d $DIR"/.henplus/lib" ]; then
CUSTOM_HENPLUSDIR=$DIR"/.henplus/lib"
- break
+ break
fi
DIR=`dirname $DIR`
done
diff --git a/dev-db/henplus/henplus-0.9.7-r1.ebuild b/dev-db/henplus/henplus-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..b9a3609c07ed
--- /dev/null
+++ b/dev-db/henplus/henplus-0.9.7-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/henplus/henplus-0.9.7-r1.ebuild,v 1.1 2007/05/07 16:29:59 betelgeuse Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 eutils java-ant-2
+
+DESCRIPTION="Java-based multisession SQL shell for databases with JDBC support."
+HOMEPAGE="http://henplus.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="=dev-java/commons-cli-1*
+ dev-java/libreadline-java"
+RDEPEND=">=virtual/jre-1.3
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.3
+ ${COMMON_DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+
+ cd lib
+ rm -v *.jar build/*.jar || die
+ java-pkg_jar-from commons-cli-1 commons-cli.jar
+ java-pkg_jar-from libreadline-java libreadline-java.jar
+}
+
+src_install () {
+ java-pkg_dojar "build/${PN}.jar"
+
+ java-pkg_dolauncher ${PN} -pre "${FILESDIR}/${PN}.pre" \
+ --main henplus.HenPlus
+
+ dodoc README || die
+ dohtml doc/HenPlus.html || die
+ use doc && java-pkg_dojavadoc javadoc/api
+
+ use source && java-pkg_dosrc "src/${PN}"
+}
+