summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-06 05:03:05 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-06 05:03:05 +0000
commitbb74e74f5f6daf17eb8211b8464fed7313a5ff8d (patch)
tree621aa4d0258a37043ebf5a2058d48036260feec6 /dev-cpp
parentVersion bump wrt bug 541606 (diff)
downloadgentoo-2-bb74e74f5f6daf17eb8211b8464fed7313a5ff8d.tar.gz
gentoo-2-bb74e74f5f6daf17eb8211b8464fed7313a5ff8d.tar.bz2
gentoo-2-bb74e74f5f6daf17eb8211b8464fed7313a5ff8d.zip
Add multilib support.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/ChangeLog10
-rw-r--r--dev-cpp/glibmm/glibmm-2.42.0-r1.ebuild84
2 files changed, 92 insertions, 2 deletions
diff --git a/dev-cpp/glibmm/ChangeLog b/dev-cpp/glibmm/ChangeLog
index b3d95fce61f4..c03ce28bee52 100644
--- a/dev-cpp/glibmm/ChangeLog
+++ b/dev-cpp/glibmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/glibmm
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.229 2014/12/21 12:18:54 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.230 2015/03/06 05:03:05 tetromino Exp $
+
+*glibmm-2.42.0-r1 (06 Mar 2015)
+
+ 06 Mar 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +glibmm-2.42.0-r1.ebuild:
+ Add multilib support.
*glibmm-2.42.0 (21 Dec 2014)
diff --git a/dev-cpp/glibmm/glibmm-2.42.0-r1.ebuild b/dev-cpp/glibmm/glibmm-2.42.0-r1.ebuild
new file mode 100644
index 000000000000..38179613983d
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.42.0-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.42.0-r1.ebuild,v 1.1 2015/03/06 05:03:05 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug examples test"
+
+COMMON_DEPEND="
+ >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.42:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtkmmlibs-20140508
+ !app-emulation/emul-linux-x86-gtkmmlibs[-abi_x86_32(-)] )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+
+ # Test fails with IPv6 but not v4, upstream bug #720073
+ sed -e 's:giomm_tls_client/test::' \
+ -i tests/Makefile.{am,in} || die
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable debug debug-refcounting) \
+ $(multilib_native_use_enable doc documentation) \
+ --enable-deprecated-api
+}
+
+multilib_src_test() {
+ cd tests
+ default
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if ! use doc && ! use examples; then
+ rm -fr "${ED}usr/share/doc/glibmm*"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc -r examples
+ fi
+}