summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2009-01-19 11:11:40 +0000
committerIlya Volynets <iluxa@gentoo.org>2009-01-19 11:11:40 +0000
commit63961f28850e49c3af439836c65f315c5a90d93f (patch)
tree63539291c0722478410c888fed1262fb18555994 /dev-cpp
parentAdd ~arm/~sh (diff)
downloadgentoo-2-63961f28850e49c3af439836c65f315c5a90d93f.tar.gz
gentoo-2-63961f28850e49c3af439836c65f315c5a90d93f.tar.bz2
gentoo-2-63961f28850e49c3af439836c65f315c5a90d93f.zip
Add sptk-3.5.8.9
(Portage version: 2.1.6.4/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog10
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.9.ebuild80
2 files changed, 88 insertions, 2 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 2e6a45a7b6ca..0b9e557a9dc5 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.48 2008/12/19 00:19:28 iluxa Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.49 2009/01/19 11:11:40 iluxa Exp $
+
+*sptk-3.5.8.9 (19 Jan 2009)
+
+ 19 Jan 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.8.9.ebuild:
+ Add sptk-3.5.8.9
19 Dec 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
sptk-3.5.7.13.ebuild, sptk-3.5.8.8.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.5.8.9.ebuild b/dev-cpp/sptk/sptk-3.5.8.9.ebuild
new file mode 100644
index 000000000000..c42d60fc60c4
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.8.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2006-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.9.ebuild,v 1.1 2009/01/19 11:11:40 iluxa Exp $
+
+EAPI=1
+
+inherit eutils flag-o-matic multilib
+
+IUSE="fltk odbc doc sqlite examples excel postgres aspell mysql"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( BSD )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite? ( >=dev-db/sqlite-3 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( dev-db/mysql )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ doc? ( app-doc/doxygen )"
+
+check_use() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ check_use examples EXAMPLES
+ check_use postgres POSTGRESQL
+ check_use mysql MYSQL
+ check_use sqlite3 SQLITE3
+ check_use odbc ODBC
+ check_use aspell ASPELL
+ check_use fltk FLTK
+ check_use excel EXCEL
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}