summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2008-05-06 05:01:52 +0000
committerIlya Volynets <iluxa@gentoo.org>2008-05-06 05:01:52 +0000
commit08ef8e65a3c5179f16d157694603502cbdf23527 (patch)
tree48f8b050eb62f117afe583e102e6ddf960df2bcd /dev-cpp
parentVersion bump. (diff)
downloadgentoo-2-08ef8e65a3c5179f16d157694603502cbdf23527.tar.gz
gentoo-2-08ef8e65a3c5179f16d157694603502cbdf23527.tar.bz2
gentoo-2-08ef8e65a3c5179f16d157694603502cbdf23527.zip
Add SPTK-3.5.7.10
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog6
-rw-r--r--dev-cpp/sptk/sptk-3.5.7.10.ebuild76
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index f98b5e69f625..969e93b2b21e 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.30 2008/03/17 05:13:39 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.31 2008/05/06 05:01:52 iluxa Exp $
+
+ 06 May 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.7.10.ebuild:
+ Add SPTK-3.5.7.10
17 Mar 2008; <ricmm@gentoo.org> sptk-3.2.6.ebuild:
Drop to ~mips due to unstable deps
diff --git a/dev-cpp/sptk/sptk-3.5.7.10.ebuild b/dev-cpp/sptk/sptk-3.5.7.10.ebuild
new file mode 100644
index 000000000000..f317d0ef3d15
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.7.10.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2006-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.10.ebuild,v 1.1 2008/05/06 05:01:52 iluxa Exp $
+
+inherit eutils flag-o-matic autotools
+
+IUSE="fltk odbc doc sqlite3 excel postgres aspell"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( BSD )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="dev-util/cmake
+ fltk? ( >=x11-libs/fltk-1.1.6 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ postgres? ( >=dev-db/libpq-8.0 )
+ aspell? ( >=app-text/aspell-0.50 )
+ doc? ( app-doc/doxygen )"
+
+check_use() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ check_use examples EXAMPLES
+ check_use postgres POSTGRESQL
+ check_use sqlite3 SQLITE3
+ check_use odbc ODBC
+ check_use aspell ASPELL
+ check_use fltk FLTK
+ check_use excel EXCEL
+
+ sed -r -i -e 's|SET \(LIBRARY_TYPE STATIC\)|SET \(LIBRARY_TYPE SHARED\)|' src/CMakeLists.txt
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}