summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-04-11 16:27:57 +0000
committerRémi Cardona <remi@gentoo.org>2008-04-11 16:27:57 +0000
commitf561d6af6f10f502393d67a09c81c1421756be82 (patch)
treeac0aed858b2396f77626b7f8244466ffdd9dac2a /dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild
parentwhitespace (diff)
downloadgentoo-2-f561d6af6f10f502393d67a09c81c1421756be82.tar.gz
gentoo-2-f561d6af6f10f502393d67a09c81c1421756be82.tar.bz2
gentoo-2-f561d6af6f10f502393d67a09c81c1421756be82.zip
dev-cpp/libxmlpp: Bump to 2.22.0, fix leak and fix for gcc 4.3
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild')
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild
new file mode 100644
index 000000000000..b346f92f3647
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.22.0.ebuild,v 1.1 2008/04/11 16:27:57 remi Exp $
+
+inherit gnome2 eutils
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm -fr "${D}"/usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}