summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-12-19 11:46:12 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-12-19 11:46:12 +0000
commit6dbe64e6f39ef5ae0588bbaa08d664cd61bc5d94 (patch)
tree02feb2a1a1904daa610b2550abf38abb9b868416 /dev-cpp/ctemplate
parentVersion bump, wrt bug #532976 (diff)
downloadgentoo-2-6dbe64e6f39ef5ae0588bbaa08d664cd61bc5d94.tar.gz
gentoo-2-6dbe64e6f39ef5ae0588bbaa08d664cd61bc5d94.tar.bz2
gentoo-2-6dbe64e6f39ef5ae0588bbaa08d664cd61bc5d94.zip
Version bump, wrt bug #532976
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog7
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.3.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index 6273f398d3cd..2df379cbd9c8 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.30 2014/12/19 09:24:37 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.31 2014/12/19 11:46:12 pinkbyte Exp $
+
+*ctemplate-2.3 (19 Dec 2014)
+
+ 19 Dec 2014; Sergey Popov <pinkbyte@gentoo.org> +ctemplate-2.3.ebuild:
+ Version bump, wrt bug #532976
19 Dec 2014; Sergey Popov <pinkbyte@gentoo.org> ctemplate-2.2_p129.ebuild:
Stable on amd64 and x86, wrt bug #529414
diff --git a/dev-cpp/ctemplate/ctemplate-2.3.ebuild b/dev-cpp/ctemplate/ctemplate-2.3.ebuild
new file mode 100644
index 000000000000..5518518e83d5
--- /dev/null
+++ b/dev-cpp/ctemplate/ctemplate-2.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-2.3.ebuild,v 1.1 2014/12/19 11:46:12 pinkbyte Exp $
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 )
+inherit autotools-utils elisp-common python-any-r1
+
+DESCRIPTION="A simple but powerful template language for C++"
+HOMEPAGE="http://code.google.com/p/ctemplate/"
+SRC_URI="http://dev.gentoo.org/~pinkbyte/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax static-libs test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
+ emacs? ( virtual/emacs )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+SITEFILE="70ctemplate-gentoo.el"
+
+# Some tests are broken in 2.3
+RESTRICT="test"
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use emacs ; then
+ elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+
+ use doc && dohtml doc/*
+
+ if use vim-syntax ; then
+ cd "${S}/contrib"
+ sh highlighting.vim || die "unpacking vim scripts failed"
+ insinto /usr/share/vim/vimfiles
+ doins -r .vim/*
+ fi
+
+ if use emacs ; then
+ cd "${S}/contrib"
+ elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}