summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-07 14:07:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-07 14:07:50 +0000
commit1fe7947327f7d325b8e7b2f0cb80cf68e5a40030 (patch)
tree3c9a10677103b29a73c2e0b9cb7e64c1df992bb4 /dev-cpp/clucene/clucene-0.9.21b.ebuild
parentVersion bump (diff)
downloadgentoo-2-1fe7947327f7d325b8e7b2f0cb80cf68e5a40030.tar.gz
gentoo-2-1fe7947327f7d325b8e7b2f0cb80cf68e5a40030.tar.bz2
gentoo-2-1fe7947327f7d325b8e7b2f0cb80cf68e5a40030.zip
Version bump. Removing old (quite few issues with kde4 here).
Add myself as maintainer, also add kde-herd since we need this package for strigi. This commit closes bug 244302 as WONTFIX for now. (Portage version: 2.2_rc13/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-cpp/clucene/clucene-0.9.21b.ebuild')
-rw-r--r--dev-cpp/clucene/clucene-0.9.21b.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/clucene/clucene-0.9.21b.ebuild b/dev-cpp/clucene/clucene-0.9.21b.ebuild
new file mode 100644
index 000000000000..2f939964afda
--- /dev/null
+++ b/dev-cpp/clucene/clucene-0.9.21b.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/clucene-0.9.21b.ebuild,v 1.1 2008/11/07 14:07:50 scarabeus Exp $
+
+MY_P=${PN}-core-${PV}
+
+DESCRIPTION="High-performance, full-featured text search engine based off of lucene in C++"
+HOMEPAGE="http://clucene.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clucene/${MY_P}.tar.bz2"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc threads"
+
+DEPEND="doc? ( >=app-doc/doxygen-1.4.2 )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable debug) \
+ $(use_enable debug cnddebug) \
+ $(use_enable threads multithreading) || die "econf failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake doxygen || die "making docs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+ use doc && dohtml "${S}"/doc/html/*
+}