summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2003-08-14 02:14:10 +0000
committerDavid Holm <dholm@gentoo.org>2003-08-14 02:14:10 +0000
commit8e2f741fa568ef15c318d32308f6085098973b3c (patch)
tree638399d173a079e5800bcd135948835f1b961414 /dev-ada
parentInitial release. OpenGL bindings to Ada. (diff)
downloadgentoo-2-8e2f741fa568ef15c318d32308f6085098973b3c.tar.gz
gentoo-2-8e2f741fa568ef15c318d32308f6085098973b3c.tar.bz2
gentoo-2-8e2f741fa568ef15c318d32308f6085098973b3c.zip
Initial release. OpenGL bindings to Ada.
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/adaopengl/ChangeLog12
-rw-r--r--dev-ada/adaopengl/Manifest4
-rw-r--r--dev-ada/adaopengl/adaopengl-0.12.ebuild32
-rw-r--r--dev-ada/adaopengl/files/digest-adaopengl-0.121
-rw-r--r--dev-ada/adaopengl/metadata.xml5
5 files changed, 52 insertions, 2 deletions
diff --git a/dev-ada/adaopengl/ChangeLog b/dev-ada/adaopengl/ChangeLog
new file mode 100644
index 000000000000..d008a5c3c226
--- /dev/null
+++ b/dev-ada/adaopengl/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-ada/adaopengl
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/adaopengl/ChangeLog,v 1.1 2003/08/14 02:13:33 dholm Exp $
+
+*adaopengl-0.12 (14 Aug 2003)
+
+ 14 Aug 2003; David Holm <avatar@gentoo.org> adaopengl-0.12.ebuild,
+ metadata.xml:
+ Initial release (#26444)
+ OpenGL bindings to the Ada language.
+ I both wrote the bindings and submitted the ebuild, lucky me.
+
diff --git a/dev-ada/adaopengl/Manifest b/dev-ada/adaopengl/Manifest
index 9ff4b253b090..e5f0085caaaa 100644
--- a/dev-ada/adaopengl/Manifest
+++ b/dev-ada/adaopengl/Manifest
@@ -1,4 +1,4 @@
-MD5 5a2a4bdd6a4f2d6533cd6a942c35c1f2 adaopengl-0.12.ebuild 683
-MD5 2013deae5d94eea2f93159baaf34e3f1 ChangeLog 373
+MD5 95c1d51459ec895c606089142388624e adaopengl-0.12.ebuild 784
+MD5 db25a646d7b30585abb96eb693071906 ChangeLog 462
MD5 e8e274a5057d2f205a38206204250c79 metadata.xml 156
MD5 a530b6a95c00934d12c53f0a23d574c8 files/digest-adaopengl-0.12 66
diff --git a/dev-ada/adaopengl/adaopengl-0.12.ebuild b/dev-ada/adaopengl/adaopengl-0.12.ebuild
new file mode 100644
index 000000000000..922bbe8c838c
--- /dev/null
+++ b/dev-ada/adaopengl/adaopengl-0.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/adaopengl/adaopengl-0.12.ebuild,v 1.1 2003/08/14 02:13:33 dholm Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="This is an Ada-binding to OpenGL and some of it's related libraries."
+SRC_URI="mirror://sourceforge/adaopengl/${P}.tar.bz2"
+HOMEPAGE="http://adaopengl.sourceforge.net/"
+LICENSE="BSD"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="dev-lang/gnat
+ dev-ada/adabindx"
+RDEPEND="virtual/opengl"
+
+inherit gnat
+
+src_compile() {
+ # This should not be here ;)
+ rm ${S}/adaopengl/adagl.ads
+
+ emake || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr install || die
+
+ # Install documentation.
+ dodoc Changelog COPYING Readme TODO
+}
diff --git a/dev-ada/adaopengl/files/digest-adaopengl-0.12 b/dev-ada/adaopengl/files/digest-adaopengl-0.12
new file mode 100644
index 000000000000..cec762f88df2
--- /dev/null
+++ b/dev-ada/adaopengl/files/digest-adaopengl-0.12
@@ -0,0 +1 @@
+MD5 0aa9001981221d4f1845b649b865cdd8 adaopengl-0.12.tar.bz2 47870
diff --git a/dev-ada/adaopengl/metadata.xml b/dev-ada/adaopengl/metadata.xml
new file mode 100644
index 000000000000..aec150231c3f
--- /dev/null
+++ b/dev-ada/adaopengl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+</pkgmetadata>