summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-12 06:33:54 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-12 06:33:54 +0000
commite28913b87d56dce353f1f5a080bcc308cb3b1bcc (patch)
treef10fbabb5e70e2bd57978fbcd93d0f12e5507fb2 /app-vim
parentRespect user CFLAGS. (diff)
downloadgentoo-2-e28913b87d56dce353f1f5a080bcc308cb3b1bcc.tar.gz
gentoo-2-e28913b87d56dce353f1f5a080bcc308cb3b1bcc.tar.bz2
gentoo-2-e28913b87d56dce353f1f5a080bcc308cb3b1bcc.zip
Version bump.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/easytags/ChangeLog7
-rw-r--r--app-vim/easytags/easytags-2.4.11.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/app-vim/easytags/ChangeLog b/app-vim/easytags/ChangeLog
index 859e081815e5..ffd81d72bffd 100644
--- a/app-vim/easytags/ChangeLog
+++ b/app-vim/easytags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/easytags
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.1 2011/06/29 00:40:50 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.2 2011/07/12 06:33:54 radhermit Exp $
+
+*easytags-2.4.11 (12 Jul 2011)
+
+ 12 Jul 2011; Tim Harder <radhermit@gentoo.org> +easytags-2.4.11.ebuild:
+ Version bump.
*easytags-2.4.9 (29 Jun 2011)
diff --git a/app-vim/easytags/easytags-2.4.11.ebuild b/app-vim/easytags/easytags-2.4.11.ebuild
new file mode 100644
index 000000000000..0a05581e972f
--- /dev/null
+++ b/app-vim/easytags/easytags-2.4.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/easytags-2.4.11.ebuild,v 1.1 2011/07/12 06:33:54 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="easytags.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ rm INSTALL.md README.md
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ # Make scripts executable
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+}