summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-04-27 09:12:00 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-04-27 09:12:00 +0000
commit8590f5443902b7ee91cfa1373d2670564b678d4a (patch)
treee7c48a0d3b26e2d6578f5e20d43eae3e6aa2989b /app-vim/python-mode
parentVersion bump. (diff)
downloadgentoo-2-8590f5443902b7ee91cfa1373d2670564b678d4a.tar.gz
gentoo-2-8590f5443902b7ee91cfa1373d2670564b678d4a.tar.bz2
gentoo-2-8590f5443902b7ee91cfa1373d2670564b678d4a.zip
Initial import, ebuild written by me
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/python-mode')
-rw-r--r--app-vim/python-mode/ChangeLog10
-rw-r--r--app-vim/python-mode/metadata.xml15
-rw-r--r--app-vim/python-mode/python-mode-0.6.3.ebuild52
3 files changed, 77 insertions, 0 deletions
diff --git a/app-vim/python-mode/ChangeLog b/app-vim/python-mode/ChangeLog
new file mode 100644
index 000000000000..03bd0080582f
--- /dev/null
+++ b/app-vim/python-mode/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/python-mode
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.1 2012/04/27 09:12:00 xarthisius Exp $
+
+*python-mode-0.6.3 (27 Apr 2012)
+
+ 27 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +python-mode-0.6.3.ebuild, +metadata.xml:
+ Initial import, ebuild written by me
+
diff --git a/app-vim/python-mode/metadata.xml b/app-vim/python-mode/metadata.xml
new file mode 100644
index 000000000000..e161ac80972e
--- /dev/null
+++ b/app-vim/python-mode/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>
+ Python-mode is a vim plugin that allows you to use the pylint, rope,
+ pydoc, pyflakes, pep8, mccabe libraries in vim to provide features like
+ python code looking for bugs, refactoring and some other useful
+ things.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-vim/python-mode/python-mode-0.6.3.ebuild b/app-vim/python-mode/python-mode-0.6.3.ebuild
new file mode 100644
index 000000000000..0c1cbb95a616
--- /dev/null
+++ b/app-vim/python-mode/python-mode-0.6.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/python-mode-0.6.3.ebuild,v 1.1 2012/04/27 09:12:00 xarthisius Exp $
+
+EAPI=4
+
+VIM_PLUGIN_MESSAGES="filetype"
+VIM_PLUGIN_HELPFILES="PythonModeCommands"
+VIM_PLUGIN_HELPURI="https://github.com/klen/python-mode"
+
+inherit vim-plugin
+
+DESCRIPTION="Provide python code looking for bugs, refactoring and other useful things"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3770 https://github.com/klen/python-mode"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=17788 -> ${P}.zip"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="
+ dev-python/astng
+ dev-python/pep8
+ dev-python/pyflakes
+ dev-python/pylint
+ dev-python/rope
+ dev-python/ropemode
+ "
+
+GIT_REV=9956aba
+S=${WORKDIR}/klen-${PN}-${GIT_REV}
+
+src_prepare() {
+ rm -rf pylibs/{logilab,pep8.py,pyflakes,pylint,rope,ropemode} .gitignore
+ mv pylint.ini "${T}" || die
+ sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
+ -i plugin/pymode.vim || die # use custom path
+}
+
+src_install() {
+ vim-plugin_src_install
+ insinto usr/share/${PN}
+ doins "${T}"/pylint.ini
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ einfo "If you use custom pylintrc make sure you append the contents of"
+ einfo " ${EPREFIX}/usr/share/${PN}/pylint.ini"
+ einfo "to it. Otherwise PyLint command will not work properly."
+}