summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-08-03 08:20:03 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-08-03 08:20:03 +0000
commit30e5638417b01389ca5f502d75b1a80afad557ff (patch)
tree090d1f87a3df9b4dae7d3150bd939f3a9ac754a9 /app-vim/python-mode
parentStable on amd64 wrt bug #418949 (diff)
downloadgentoo-2-30e5638417b01389ca5f502d75b1a80afad557ff.tar.gz
gentoo-2-30e5638417b01389ca5f502d75b1a80afad557ff.tar.bz2
gentoo-2-30e5638417b01389ca5f502d75b1a80afad557ff.zip
Version bump, drop old. Remove bundled autopep8
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/python-mode')
-rw-r--r--app-vim/python-mode/ChangeLog9
-rw-r--r--app-vim/python-mode/python-mode-0.6.6.ebuild (renamed from app-vim/python-mode/python-mode-0.6.4.ebuild)8
2 files changed, 12 insertions, 5 deletions
diff --git a/app-vim/python-mode/ChangeLog b/app-vim/python-mode/ChangeLog
index 2a1165ec29b0..4d5aa18ca6fc 100644
--- a/app-vim/python-mode/ChangeLog
+++ b/app-vim/python-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/python-mode
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.2 2012/05/25 10:42:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/ChangeLog,v 1.3 2012/08/03 08:20:02 xarthisius Exp $
+
+*python-mode-0.6.6 (03 Aug 2012)
+
+ 03 Aug 2012; Kacper Kowalik <xarthisius@gentoo.org> +python-mode-0.6.6.ebuild,
+ -python-mode-0.6.4.ebuild:
+ Version bump, drop old. Remove bundled autopep8
*python-mode-0.6.4 (25 May 2012)
@@ -15,4 +21,3 @@
27 Apr 2012; Kacper Kowalik <xarthisius@gentoo.org>
+python-mode-0.6.3.ebuild, +metadata.xml:
Initial import, ebuild written by me
-
diff --git a/app-vim/python-mode/python-mode-0.6.4.ebuild b/app-vim/python-mode/python-mode-0.6.6.ebuild
index 648a2e43a87c..eb2b1dd903c0 100644
--- a/app-vim/python-mode/python-mode-0.6.4.ebuild
+++ b/app-vim/python-mode/python-mode-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/python-mode-0.6.4.ebuild,v 1.1 2012/05/25 10:42:32 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/python-mode/python-mode-0.6.6.ebuild,v 1.1 2012/08/03 08:20:02 xarthisius Exp $
EAPI=4
@@ -21,7 +21,7 @@ IUSE=""
DEPEND=""
RDEPEND="
dev-python/astng
- dev-python/pep8
+ dev-python/autopep8
dev-python/pyflakes
dev-python/pylint
dev-python/rope
@@ -29,10 +29,12 @@ RDEPEND="
"
src_prepare() {
- rm -rf pylibs/{logilab,pep8.py,pyflakes,pylint,rope,ropemode} .gitignore
+ rm -rf pylibs/{logilab,*pep8.py,pyflakes,pylint,rope,ropemode} .gitignore
mv pylint.ini "${T}" || die
sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
-i plugin/pymode.vim || die # use custom path
+ sed -e "s/pylibs.autopep8/autopep8/g" -i pylibs/pymode/auto.py || die
+ sed -e "s/pylibs.ropemode/ropemode/g" -i pylibs/ropevim.py || die
}
src_install() {