summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-09-20 08:05:29 +0000
committerAli Polatel <hawking@gentoo.org>2008-09-20 08:05:29 +0000
commit0b631be506f3acf76441df9b0177bae4da5ee564 (patch)
tree0ab724295912e3d8075d3333c95f4ff412b4fa63 /app-vim/alternate
parentppc stable, bug #237913 (diff)
downloadgentoo-2-0b631be506f3acf76441df9b0177bae4da5ee564.tar.gz
gentoo-2-0b631be506f3acf76441df9b0177bae4da5ee564.tar.bz2
gentoo-2-0b631be506f3acf76441df9b0177bae4da5ee564.zip
Version bump. Quoting.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'app-vim/alternate')
-rw-r--r--app-vim/alternate/ChangeLog10
-rw-r--r--app-vim/alternate/alternate-2.12-r1.ebuild8
-rw-r--r--app-vim/alternate/alternate-2.15.ebuild6
-rw-r--r--app-vim/alternate/alternate-2.18.ebuild24
4 files changed, 39 insertions, 9 deletions
diff --git a/app-vim/alternate/ChangeLog b/app-vim/alternate/ChangeLog
index 22e134a2fa3b..e6c7e2b9f74b 100644
--- a/app-vim/alternate/ChangeLog
+++ b/app-vim/alternate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/alternate
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/ChangeLog,v 1.39 2007/02/21 23:51:39 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/ChangeLog,v 1.40 2008/09/20 08:05:29 hawking Exp $
+
+*alternate-2.18 (20 Sep 2008)
+
+ 20 Sep 2008; Ali Polatel <hawking@gentoo.org> alternate-2.12-r1.ebuild,
+ +alternate-2.18.ebuild:
+ Version bump. Quoting.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-vim/alternate/alternate-2.12-r1.ebuild b/app-vim/alternate/alternate-2.12-r1.ebuild
index f246a53b423a..4234f6059415 100644
--- a/app-vim/alternate/alternate-2.12-r1.ebuild
+++ b/app-vim/alternate/alternate-2.12-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/alternate-2.12-r1.ebuild,v 1.6 2005/09/10 06:30:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/alternate-2.12-r1.ebuild,v 1.7 2008/09/20 08:05:29 hawking Exp $
inherit vim-plugin eutils
@@ -18,7 +18,7 @@ file and the associated .h file. There is also :AS to split windows and
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# fix switching between .cc and .hh files, thanks ciaranm
- epatch ${FILESDIR}/${P}-hh-cc-alternation.patch
+ epatch "${FILESDIR}"/${P}-hh-cc-alternation.patch
}
diff --git a/app-vim/alternate/alternate-2.15.ebuild b/app-vim/alternate/alternate-2.15.ebuild
index 8bb21ed00cd5..849fdceec689 100644
--- a/app-vim/alternate/alternate-2.15.ebuild
+++ b/app-vim/alternate/alternate-2.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/alternate-2.15.ebuild,v 1.1 2007/01/04 02:47:53 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/alternate-2.15.ebuild,v 1.2 2008/09/20 08:05:29 hawking Exp $
inherit vim-plugin eutils
@@ -18,7 +18,7 @@ file and the associated .h file. There is also :AS to split windows and
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# fix switching between .cc and .hh files, thanks ciaranm
- epatch ${FILESDIR}/${PN}-2.12-hh-cc-alternation.patch
+ epatch "${FILESDIR}"/${PN}-2.12-hh-cc-alternation.patch
}
diff --git a/app-vim/alternate/alternate-2.18.ebuild b/app-vim/alternate/alternate-2.18.ebuild
new file mode 100644
index 000000000000..acffda22ad5b
--- /dev/null
+++ b/app-vim/alternate/alternate-2.18.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/alternate/alternate-2.18.ebuild,v 1.1 2008/09/20 08:05:29 hawking Exp $
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: quickly switch between .c and .h files"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=31"
+
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a new :A command which will switch between a .c
+file and the associated .h file. There is also :AS to split windows and
+:AV to split windows vertiically."
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # fix switching between .cc and .hh files, thanks ciaranm
+ epatch "${FILESDIR}"/${PN}-2.12-hh-cc-alternation.patch
+}