summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-09 00:06:47 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-09 00:06:47 +0000
commitf56039979134000cde2cc3640dc898f2fc55e85e (patch)
tree8cc387b9afb58017038b1010721abd284962e862 /app-text
parentDrop runtime dependency on xcb-proto, bug #398953. (diff)
downloadgentoo-2-f56039979134000cde2cc3640dc898f2fc55e85e.tar.gz
gentoo-2-f56039979134000cde2cc3640dc898f2fc55e85e.tar.bz2
gentoo-2-f56039979134000cde2cc3640dc898f2fc55e85e.zip
Fix building with libtool-2.4 #342669 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dictd/ChangeLog8
-rw-r--r--app-text/dictd/dictd-1.12.0.ebuild9
-rw-r--r--app-text/dictd/files/dictd-1.12.0-build.patch22
3 files changed, 33 insertions, 6 deletions
diff --git a/app-text/dictd/ChangeLog b/app-text/dictd/ChangeLog
index 218958c25d11..40b21e1bacb0 100644
--- a/app-text/dictd/ChangeLog
+++ b/app-text/dictd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/dictd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.88 2011/06/28 10:22:14 pva Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/ChangeLog,v 1.89 2012/02/09 00:06:47 vapier Exp $
+
+ 09 Feb 2012; Mike Frysinger <vapier@gentoo.org> dictd-1.12.0.ebuild,
+ +files/dictd-1.12.0-build.patch:
+ Fix building with libtool-2.4 #342669 by Diego Elio Pettenò.
*dictd-1.12.0 (28 Jun 2011)
diff --git a/app-text/dictd/dictd-1.12.0.ebuild b/app-text/dictd/dictd-1.12.0.ebuild
index 1e39df902efa..b5977b0461bf 100644
--- a/app-text/dictd/dictd-1.12.0.ebuild
+++ b/app-text/dictd/dictd-1.12.0.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.12.0.ebuild,v 1.1 2011/06/28 10:22:15 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.12.0.ebuild,v 1.2 2012/02/09 00:06:47 vapier Exp $
EAPI="4"
inherit eutils
DESCRIPTION="Dictionary Client/Server for the DICT protocol"
-HOMEPAGE="http://www.dict.org/"
+HOMEPAGE="http://www.dict.org/ http://sourceforge.net/projects/dict/"
SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
SLOT="0"
@@ -32,7 +32,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/dictd-1.10.11-colorit-nopp-fix.patch"
+ epatch "${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
+ epatch "${FILESDIR}"/dictd-1.12.0-build.patch
[[ ${CHOST} == *-darwin* ]] && \
sed -i -e 's:libtool:glibtool:g' Makefile.in
diff --git a/app-text/dictd/files/dictd-1.12.0-build.patch b/app-text/dictd/files/dictd-1.12.0-build.patch
new file mode 100644
index 000000000000..d192f8ccb961
--- /dev/null
+++ b/app-text/dictd/files/dictd-1.12.0-build.patch
@@ -0,0 +1,22 @@
+don't force -static so we get both pic and non-pic objects
+
+https://bugs.gentoo.org/342669
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -117,12 +117,12 @@
+ @SET_MAKE@
+
+ %.o: %.c
+- $(LIBTOOL) --tag=CC --mode=compile $(CC) -c $(CFLAGS) $< -o $@
++ $(LIBTOOL) --tag=CC --mode=compile $(CC) -c $(CFLAGS) $< -o $@ -static
+ %.o: %.cpp
+- $(LIBTOOL) --tag=CXX --mode=compile $(CXX) -c $(CFLAGS) $< -o $@
++ $(LIBTOOL) --tag=CXX --mode=compile $(CXX) -c $(CFLAGS) $< -o $@ -static
+
+ %: %.o
+- $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ -static \
++ $(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ \
+ $^ $(OBJS) $(LDFLAGS) -lz ${LIBS}
+
+ include $(srcdir)/deps