summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Hrušecký <miska@gentoo.org>2011-06-19 20:09:40 +0000
committerMichal Hrušecký <miska@gentoo.org>2011-06-19 20:09:40 +0000
commitbbf6eb612434871cc216e1d97ff216591b4caf66 (patch)
treeb8b8b7f0b2e3d1126642510012e9f4647cc4d1ef /app-text
parentVersion bump (diff)
downloadgentoo-2-bbf6eb612434871cc216e1d97ff216591b4caf66.tar.gz
gentoo-2-bbf6eb612434871cc216e1d97ff216591b4caf66.tar.bz2
gentoo-2-bbf6eb612434871cc216e1d97ff216591b4caf66.zip
New ebuild for pspdftool. Ebuild written by me.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pspdftool/ChangeLog11
-rw-r--r--app-text/pspdftool/metadata.xml13
-rw-r--r--app-text/pspdftool/pspdftool-0.03.ebuild37
-rw-r--r--app-text/pspdftool/pspdftool-9999.ebuild37
4 files changed, 98 insertions, 0 deletions
diff --git a/app-text/pspdftool/ChangeLog b/app-text/pspdftool/ChangeLog
new file mode 100644
index 000000000000..13cc907c9ffa
--- /dev/null
+++ b/app-text/pspdftool/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/pspdftool
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspdftool/ChangeLog,v 1.1 2011/06/19 20:09:40 miska Exp $
+
+*pspdftool-9999 (19 Jun 2011)
+*pspdftool-0.03 (19 Jun 2011)
+
+ 19 Jun 2011; Michal Hrusecky <miska@gentoo.org> +pspdftool-0.03.ebuild,
+ +pspdftool-9999.ebuild, +metadata.xml:
+ New ebuild for pspdftool. Ebuild written by me.
+
diff --git a/app-text/pspdftool/metadata.xml b/app-text/pspdftool/metadata.xml
new file mode 100644
index 000000000000..90741ecbdcc4
--- /dev/null
+++ b/app-text/pspdftool/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>miska@gentoo.org</email>
+<name>Michal Hrušecký</name>
+</maintainer>
+<longdescription lang="en">
+Pspdftool is a tool for preprinting preparation of documents. It supports PostScript and PDF files and allows users do several transformations (for example rotation, scale, miror ...) and pages selections.
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-text/pspdftool/pspdftool-0.03.ebuild b/app-text/pspdftool/pspdftool-0.03.ebuild
new file mode 100644
index 000000000000..625e1eeb57c8
--- /dev/null
+++ b/app-text/pspdftool/pspdftool-0.03.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspdftool/pspdftool-0.03.ebuild,v 1.1 2011/06/19 20:09:40 miska Exp $
+
+EAPI=4
+
+ESVN_REPO_URI="https://pspdftool.svn.sourceforge.net/svnroot/pspdftool/trunk"
+ESVN_PROJECT="pspdftool"
+
+[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
+inherit autotools-utils ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
+HOMEPAGE="http://sourceforge.net/projects/pspdftool"
+[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+[[ "${PV}" == "9999" ]] || KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib ) "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}*
+}
diff --git a/app-text/pspdftool/pspdftool-9999.ebuild b/app-text/pspdftool/pspdftool-9999.ebuild
new file mode 100644
index 000000000000..e4ca65965542
--- /dev/null
+++ b/app-text/pspdftool/pspdftool-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pspdftool/pspdftool-9999.ebuild,v 1.1 2011/06/19 20:09:40 miska Exp $
+
+EAPI=4
+
+ESVN_REPO_URI="https://pspdftool.svn.sourceforge.net/svnroot/pspdftool/trunk"
+ESVN_PROJECT="pspdftool"
+
+[[ "${PV}" == "9999" ]] && EXTRA_ECLASS="subversion"
+inherit autotools-utils ${EXTRA_ECLASS}
+unset EXTRA_ECLASS
+
+DESCRIPTION="Tool for prepress preparation of PDF and PostScript documents"
+HOMEPAGE="http://sourceforge.net/projects/pspdftool"
+[[ "${PV}" == "9999" ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+[[ "${PV}" == "9999" ]] || KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="zlib"
+
+DEPEND="zlib? ( sys-libs/zlib ) "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with zlib)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}*
+}