summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-04-03 05:50:26 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-04-03 05:50:26 +0000
commit87e4533025353ae8ea2e6036b5f904dc7e49f63a (patch)
treef46950f649f9dbcc3b07f46de780afe255760dfd /app-text
parentminor changes (diff)
downloadgentoo-2-87e4533025353ae8ea2e6036b5f904dc7e49f63a.tar.gz
gentoo-2-87e4533025353ae8ea2e6036b5f904dc7e49f63a.tar.bz2
gentoo-2-87e4533025353ae8ea2e6036b5f904dc7e49f63a.zip
Testing ppc-macos. Makefile and source patches added for Darwin compatibility.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript/ChangeLog6
-rw-r--r--app-text/ghostscript/files/gs-osx-ijs.patch40
-rw-r--r--app-text/ghostscript/files/gs-osx-unix-dll.patch42
-rw-r--r--app-text/ghostscript/ghostscript-7.07.1-r8.ebuild17
4 files changed, 101 insertions, 4 deletions
diff --git a/app-text/ghostscript/ChangeLog b/app-text/ghostscript/ChangeLog
index 018ee4e04924..a1f271a9ca1c 100644
--- a/app-text/ghostscript/ChangeLog
+++ b/app-text/ghostscript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ghostscript
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.101 2005/03/27 11:59:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.102 2005/04/03 05:50:26 j4rg0n Exp $
+
+ 03 Apr 2005; Lina Pezzella <j4rg0n@gentoo.org> +files/gs-osx-ijs.patch,
+ +files/gs-osx-unix-dll.patch, ghostscript-7.07.1-r8.ebuild:
+ Testing ppc-macos. Source and Makefile patches added for Darwin compatibility.
27 Mar 2005; Bryan Østergaard <kloeri@gentoo.org>
ghostscript-7.07.1-r8.ebuild:
diff --git a/app-text/ghostscript/files/gs-osx-ijs.patch b/app-text/ghostscript/files/gs-osx-ijs.patch
new file mode 100644
index 000000000000..332a74af5a15
--- /dev/null
+++ b/app-text/ghostscript/files/gs-osx-ijs.patch
@@ -0,0 +1,40 @@
+--- ghostscript-7.07.1-r8-orig/work/espgs-7.07.1/ijs/Makefile.in Tue Apr 23 07:58:32 2002
++++ ghostscript-7.07.1-r8/work/espgs-7.07.1/ijs/Makefile.in Thu Mar 24 22:59:28 2005
+@@ -11,6 +11,12 @@
+ SHARED_OBJ=.so
+ #SHARED_LDFLAGS=-dylib
+ #SHARED_OBJ=.dylib
++
++CPU = $(shell uname)
++ifeq ($(CPU),Darwin)
++SHARED_LDFLAGS=-dynamiclib
++SHARED_OBJ=.dylib
++endif
+
+ FE=-o
+ IJS_EXEC_SERVER=ijs_exec_unix$(OBJ)
+@@ -60,8 +64,13 @@
+ $(RM) *~ gmon.out core ijs_spec.log ijs_spec.tex ijs_spec.aux libijs.a libijs$(SHARED_OBJ) config.cache config.log config.status ijs-config
+
+ install: all
++ifeq ($(CPU),Darwin)
++ $(INSTALL) ijs_client_example$(EXE) $(DESTDIR)$(bindir)/ijs_client_example$(EXE)
++ $(INSTALL) ijs-config $(DESTDIR)$(bindir)/ijs-config
++else
+ $(INSTALL) ijs_client_example$(EXE) -c $(DESTDIR)$(bindir)/ijs_client_example$(EXE)
+ $(INSTALL) ijs-config -c $(DESTDIR)$(bindir)/ijs-config
++endif
+ $(INSTALL) libijs.a $(DESTDIR)$(libdir)/libijs.a
+ $(INSTALL) libijs$(SHARED_OBJ) $(DESTDIR)$(libdir)/libijs$(SHARED_OBJ)
+ -mkdir $(DESTDIR)$(pkgincludedir)
+diff -Naur ghostscript-7.07.1-r8-orig/work/espgs-7.07.1/ijs/ijs_server_example.c ghostscript-7.07.1-r8/work/espgs-7.07.1/ijs/ijs_server_example.c
+--- ghostscript-7.07.1-r8-orig/work/espgs-7.07.1/ijs/ijs_server_example.c Tue Apr 23 10:01:17 2002
++++ ghostscript-7.07.1-r8/work/espgs-7.07.1/ijs/ijs_server_example.c Thu Mar 24 22:59:46 2005
+@@ -25,7 +25,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <malloc/malloc.h>
+ #include "ijs.h"
+ #include "ijs_server.h"
diff --git a/app-text/ghostscript/files/gs-osx-unix-dll.patch b/app-text/ghostscript/files/gs-osx-unix-dll.patch
new file mode 100644
index 000000000000..832394f51ebb
--- /dev/null
+++ b/app-text/ghostscript/files/gs-osx-unix-dll.patch
@@ -0,0 +1,42 @@
+diff -Naur ghostscript-7.07.1-r8-orig/work/espgs-7.07.1/src/unix-dll.mak ghostscript-7.07.1-r8/work/espgs-7.07.1/src/unix-dll.mak
+--- ghostscript-7.07.1-r8-orig/work/espgs-7.07.1/src/unix-dll.mak Tue Apr 23 08:43:44 2002
++++ ghostscript-7.07.1-r8/work/espgs-7.07.1/src/unix-dll.mak Thu Mar 24 23:00:57 2005
+@@ -45,12 +45,12 @@
+ GSSOX=$(BINDIR)/$(SOBINRELDIR)/$(GSSOX_XENAME)
+
+ # shared library
+-GS_SONAME=lib$(GS).so
+-GS_SONAME_MAJOR=$(GS_SONAME).$(GS_VERSION_MAJOR)
+-GS_SONAME_MAJOR_MINOR= $(GS_SONAME).$(GS_VERSION_MAJOR).$(GS_VERSION_MINOR)
++GS_SONAME=lib$(GS).dylib
++GS_SONAME_MAJOR=lib$(GS).$(GS_VERSION_MAJOR).dylib
++GS_SONAME_MAJOR_MINOR=lib$(GS).$(GS_VERSION_MAJOR).$(GS_VERSION_MINOR).dylib
+ GS_SO=$(BINDIR)/$(GS_SONAME)
+-GS_SO_MAJOR=$(GS_SO).$(GS_VERSION_MAJOR)
+-GS_SO_MAJOR_MINOR=$(GS_SO_MAJOR).$(GS_VERSION_MINOR)
++GS_SO_MAJOR=$(BINDIR)/$(GS_SONAME_MAJOR)
++GS_SO_MAJOR_MINOR=$(BINDIR)/$(GS_SONAME_MAJOR_MINOR)
+
+ # Shared object is built by redefining GS_XE in a recursive make.
+
+@@ -74,7 +74,7 @@
+
+ # ------------------------- Recursive make targets ------------------------- #
+
+-SODEFS=LDFLAGS='$(LDFLAGS) $(CFLAGS_SO) -shared -Wl,-soname,$(GS_SONAME_MAJOR)'\
++SODEFS=LDFLAGS='$(LDFLAGS) $(CFLAGS_SO) -dynamiclib -install_name $(GS_SO_MAJOR)'\
+ GS_XE=$(BINDIR)/$(SOBINRELDIR)/$(GS_SONAME_MAJOR_MINOR)\
+ STDIO_IMPLEMENTATION=c\
+ DISPLAY_DEV=$(DD)$(SOOBJRELDIR)/display.dev\
+--- ghostscript-7.07.1-r8-orig/work/espgs-7.07.1/src/unixinst.mak.orig Tue Apr 23 08:43:44 2002
++++ ghostscript-7.07.1-r8/work/espgs-7.07.1/src/unixinst.mak Thu Mar 24 23:00:57 2005
+@@ -134,7 +134,7 @@
+ ln -s ps2pdf.$(man1ext) $$f.$(man1ext) ) ;\
+ done ;\
+ fi ;\
+- if ( test -f $$man1dir/ps2ps.$(man1ext) ) ;\
++ if ( test -f $$man1dir/gslp.$(man1ext) ) ;\
+ then for f in $(MAN1_LINKS_GSLP) ;\
+ do ( cd $$man1dir; rm -f $$f.$(man1ext) ;\
+ ln -s gslp.$(man1ext) $$f.$(man1ext) ) ;\
+
diff --git a/app-text/ghostscript/ghostscript-7.07.1-r8.ebuild b/app-text/ghostscript/ghostscript-7.07.1-r8.ebuild
index f1538e84ffb4..b08c419f3635 100644
--- a/app-text/ghostscript/ghostscript-7.07.1-r8.ebuild
+++ b/app-text/ghostscript/ghostscript-7.07.1-r8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r8.ebuild,v 1.11 2005/03/27 11:59:24 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r8.ebuild,v 1.12 2005/04/03 05:50:26 j4rg0n Exp $
-inherit flag-o-matic eutils gcc
+inherit flag-o-matic eutils gcc libtool
DESCRIPTION="ESP Ghostscript -- an enhanced version of GNU Ghostscript with better printer support"
HOMEPAGE="http://www.cups.org/ghostscript.php"
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/espgs/espgs-${PV}-source.tar.bz2
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 ~ppc-macos s390 sparc x86"
IUSE="X cups cjk emacs gtk"
DEP="virtual/libc
@@ -44,6 +44,15 @@ src_unpack() {
cd ${S}
+ if use ppc-macos; then
+ epatch ${FILESDIR}/gs-osx-unix-dll.patch
+ cp src/unix-gcc.mak Makefile.in
+ sed -i -e "s:SHARE_JPEG=0:SHARE_JPEG=1:" Makefile.in || die
+ sed -i -e "s:SHARE_ZLIB=0:SHARE_ZLIB=1:" Makefile.in || die
+ sed -i -e "s:SHARE_LIBPNG=0:SHARE_LIBPNG=1:" Makefile.in || die
+ sed -i -e "s:usr/local:usr:" Makefile.in || die
+ fi
+
if use cjk ; then
epatch ${FILESDIR}/gs7.07.1-cjk.diff.bz2
epatch ${FILESDIR}/gs7.05.6-kochi-substitute.patch
@@ -66,6 +75,8 @@ src_unpack() {
epatch ${FILESDIR}/gs${PV}-destdir.patch
epatch ${FILESDIR}/gs${PV}-ijsdestdir.patch
+ use ppc-macos && epatch ${FILESDIR}/gs-osx-ijs.patch
+
# search path fix
sed -i -e "s:\$\(gsdatadir\)/lib:/usr/share/ghostscript/7.07/$(get_libdir):"\
Makefile.in || die "sed failed"