summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-12-14 17:00:57 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-12-14 17:00:57 +0000
commit389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688 (patch)
tree7344471ff2bec3014bf89db693a70a6092d1932d /app-text
parentFilter -O* on arm/ia64/sparc (bug #296901). (diff)
downloadgentoo-2-389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688.tar.gz
gentoo-2-389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688.tar.bz2
gentoo-2-389ce84b53cf3c0433a1d1c7d70b6dbdacbfa688.zip
Added RESTRICT="test", bug #171002. Replaced cjk USE flag to linguas_ja. Added a patch for obstack.h, bug #269638. clean up.
(Portage version: 2.1.7.13/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/a2ps/ChangeLog11
-rw-r--r--app-text/a2ps/a2ps-4.14-r1.ebuild112
-rw-r--r--app-text/a2ps/files/a2ps-4.14-psset.patch21
-rw-r--r--app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch14
4 files changed, 156 insertions, 2 deletions
diff --git a/app-text/a2ps/ChangeLog b/app-text/a2ps/ChangeLog
index f6308debea6b..f93dc12076fc 100644
--- a/app-text/a2ps/ChangeLog
+++ b/app-text/a2ps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/a2ps
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.86 2009/04/08 09:45:53 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/ChangeLog,v 1.87 2009/12/14 17:00:57 matsuu Exp $
+
+*a2ps-4.14-r1 (14 Dec 2009)
+
+ 14 Dec 2009; MATSUU Takuto <matsuu@gentoo.org> +a2ps-4.14-r1.ebuild,
+ +files/a2ps-4.14-psset.patch, +files/a2ps-4.14-ptrdiff_t.patch:
+ Added RESTRICT="test", bug #171002. Replaced cjk USE flag to linguas_ja.
+ Added a patch for obstack.h, bug #269638. clean up.
08 Apr 2009; Raúl Porcel <armin76@gentoo.org> a2ps-4.14.ebuild:
Add ~arm/~s390/~sh
diff --git a/app-text/a2ps/a2ps-4.14-r1.ebuild b/app-text/a2ps/a2ps-4.14-r1.ebuild
new file mode 100644
index 000000000000..ba65004c05f9
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.14-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.14-r1.ebuild,v 1.1 2009/12/14 17:00:57 matsuu Exp $
+
+inherit eutils autotools elisp-common
+
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="http://www.inf.enst.fr/~demaille/a2ps/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ linguas_ja? ( mirror://gentoo/${P}-ja_nls.patch.gz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls latex vanilla userland_BSD userland_GNU linguas_ja"
+
+RESTRICT="test"
+
+DEPEND=">=dev-util/gperf-2.7.2
+ || ( >=dev-util/yacc-1.9.1 sys-devel/bison )
+ virtual/ghostscript
+ >=app-text/psutils-1.17
+ emacs? ( virtual/emacs )
+ latex? ( virtual/latex-base )
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/ghostscript
+ app-text/wdiff
+ userland_GNU? ( || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp ) )
+ userland_BSD? ( sys-freebsd/freebsd-ubin )
+ >=app-text/psutils-1.17
+ emacs? ( virtual/emacs )
+ latex? ( virtual/latex-base )
+ nls? ( virtual/libintl )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}/${PN}-${PV:0:4}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-4.13c-locale-gentoo.diff"
+ # this will break
+ #epatch "${FILESDIR}/${PN}-4.13c-stdarg.patch"
+ use vanilla || epatch "${FILESDIR}/${PN}-4.13-stdout.diff"
+ use linguas_ja && epatch "${DISTDIR}/${P}-ja_nls.patch.gz"
+
+ # fix fnmatch replacement, bug #134546
+ epatch "${FILESDIR}/${PN}-4.13c-fnmatch-replacement.patch"
+
+ # bug #122026
+ epatch "${FILESDIR}/${P}-psset.patch"
+
+ # fix emacs printing, bug #114627
+ epatch "${FILESDIR}/a2ps-4.13c-emacs.patch"
+
+ # fix chmod error, #167670
+ epatch "${FILESDIR}/a2ps-4.13-manpage-chmod.patch"
+
+ # add configure check for mempcpy, bug 216588
+ epatch "${FILESDIR}/${P}-check-mempcpy.patch"
+
+ # fix compilation error due to invalid stpcpy() prototype, bug 216588
+ epatch "${FILESDIR}/${P}-fix-stpcpy-proto.patch"
+
+ # fix compilation error due to obstack.h issue, bug 269638
+ epatch "${FILESDIR}/${P}-ptrdiff_t.patch"
+
+ eautoreconf
+}
+
+src_compile() {
+ local myconf="COM_netscape=no COM_acroread=no"
+
+ if ! use emacs ; then
+ myconf="${myconf} EMACS=no"
+ fi
+
+ if ! use latex ; then
+ myconf="${myconf} COM_latex=no"
+ fi
+
+ export LANG=C LC_ALL=C
+
+ econf \
+ --sysconfdir=/etc/a2ps \
+ $(use_enable nls) \
+ ${myconf} || die "econf failed"
+
+ # parallel make b0rked
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+
+ dodoc ANNOUNCE AUTHORS ChangeLog FAQ NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-text/a2ps/files/a2ps-4.14-psset.patch b/app-text/a2ps/files/a2ps-4.14-psset.patch
new file mode 100644
index 000000000000..291c3aac4fa4
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.14-psset.patch
@@ -0,0 +1,21 @@
+diff -Naur a2ps-4.14.orig/contrib/psset.in a2ps-4.14/contrib/psset.in
+--- a2ps-4.14.orig/contrib/psset.in 2007-12-29 12:29:01.000000000 +0900
++++ a2ps-4.14/contrib/psset.in 2009-04-12 12:17:43.000000000 +0900
+@@ -219,7 +219,7 @@
+ done
+
+ pspagedevice="% Pagedevice definitions:
+-countdictstack
++ countdictstack
+ % Push our own mark, since there can be several PS marks pushed depending
+ % where the failure really occured.
+ /psset_mark
+@@ -227,7 +227,7 @@
+ } stopped
+ % My cleartomark
+ { /psset_mark eq { exit } if } loop
+-countdictstack exch sub dup 0 gt
++ countdictstack exch sub dup 0 gt
+ {
+ { end } repeat
+ }{
diff --git a/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch b/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch
new file mode 100644
index 000000000000..00d955a819a9
--- /dev/null
+++ b/app-text/a2ps/files/a2ps-4.14-ptrdiff_t.patch
@@ -0,0 +1,14 @@
+diff -uNr a2ps-4.14/lib/obstack.h a2ps-4.14.test/lib/obstack.h
+--- a2ps-4.14/lib/obstack.h 2007-12-29 09:37:59.000000000 +0800
++++ a2ps-4.14.test/lib/obstack.h 2009-06-10 18:49:45.000000000 +0900
+@@ -138,9 +138,9 @@
+ #define __need_ptrdiff_t
+ #endif
+ #endif
++#endif
+
+ #include <stddef.h>
+-#endif
+
+ #if defined (__STDC__) && __STDC__
+ #define PTR_INT_TYPE ptrdiff_t