summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-15 08:49:55 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-15 08:49:55 +0000
commit6618987f6438abcee2d9f2b6f3fd7e8517279e45 (patch)
tree4112c9d3a1a3369d28c00e1cfcffbbcf06d5abf8 /app-text/xmlto/xmlto-0.0.18.ebuild
parentMake this compile with GCC3.4. (Manifest recommit) (diff)
downloadgentoo-2-6618987f6438abcee2d9f2b6f3fd7e8517279e45.tar.gz
gentoo-2-6618987f6438abcee2d9f2b6f3fd7e8517279e45.tar.bz2
gentoo-2-6618987f6438abcee2d9f2b6f3fd7e8517279e45.zip
Version bumped; bug #63624.
Diffstat (limited to 'app-text/xmlto/xmlto-0.0.18.ebuild')
-rw-r--r--app-text/xmlto/xmlto-0.0.18.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/xmlto/xmlto-0.0.18.ebuild b/app-text/xmlto/xmlto-0.0.18.ebuild
new file mode 100644
index 000000000000..248ea0ee72c0
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.18.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.18.ebuild,v 1.1 2004/09/15 08:49:55 usata Exp $
+
+inherit eutils
+
+DESCRIPTION="A bash script for converting XML and DocBook formatted documents to a variety of output formats"
+HOMEPAGE="http://cyberelk.net/tim/xmlto/"
+SRC_URI="http://cyberelk.net/tim/data/xmlto/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~amd64 ~ia64 ~ppc64"
+IUSE=""
+
+DEPEND="app-shells/bash
+ dev-libs/libxslt
+ >=app-text/docbook-xsl-stylesheets-1.62.0-r1
+ >=app-text/docbook-xml-dtd-4.2"
+# tetex? ( >=app-text/passivetex-1.4 )"
+# Passivetex/xmltex need some sorting out <obz@gentoo.org>
+
+src_compile() {
+ econf || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} prefix="/usr" install || die
+ dodoc AUTHORS ChangeLog FAQ INSTALL NEWS README
+ insinto /usr/share/doc/${P}/xml
+ doins doc/*.xml
+}