summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-03 18:14:45 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-03 18:14:45 +0000
commit96eb3dc5b5f4e61dc9913250ad874b6974f4b9bc (patch)
tree5a88970900d7690f961e8dc65a7b29e639d3ba81 /app-text/xlsx2csv/xlsx2csv-0.16.ebuild
parentAdd two more patches (applied upstream), to support multiple APC UPSes and to... (diff)
downloadgentoo-2-96eb3dc5b5f4e61dc9913250ad874b6974f4b9bc.tar.gz
gentoo-2-96eb3dc5b5f4e61dc9913250ad874b6974f4b9bc.tar.bz2
gentoo-2-96eb3dc5b5f4e61dc9913250ad874b6974f4b9bc.zip
Version bump.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'app-text/xlsx2csv/xlsx2csv-0.16.ebuild')
-rw-r--r--app-text/xlsx2csv/xlsx2csv-0.16.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/xlsx2csv/xlsx2csv-0.16.ebuild b/app-text/xlsx2csv/xlsx2csv-0.16.ebuild
new file mode 100644
index 000000000000..a8a6f3b3cdeb
--- /dev/null
+++ b/app-text/xlsx2csv/xlsx2csv-0.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xlsx2csv/xlsx2csv-0.16.ebuild,v 1.1 2011/11/03 18:14:45 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Convert MS Office xlsx files to CSV"
+HOMEPAGE="https://github.com/dilshod/xlsx2csv"
+SRC_URI="mirror://github/dilshod/${PN}/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ test? ( dev-lang/python[xml] )"
+RDEPEND="dev-lang/python[xml]"
+
+S="${WORKDIR}/${PN}"
+
+src_test() {
+ local failure=0
+ for i in test/*.xlsx ; do
+ echo -n "test: $i "
+ if [[ $(basename $i) == "sheets.xlsx" ]] ; then
+ ./xlsx2csv.py -s 0 "$i" | diff -u "test/$(basename "$i" .xlsx).csv" - >/dev/null
+ else
+ ./xlsx2csv.py -i "$i" | diff -u "test/$(basename "$i" .xlsx).csv" - >/dev/null
+ fi
+ if [[ $? -ne 0 ]] ; then
+ echo "FAILED"
+ failure=1
+ else
+ echo "PASSED"
+ fi
+ done
+ [[ $failure -ne 0 ]] && die "tests failed"
+}
+
+src_install() {
+ newbin xlsx2csv.py xlsx2csv
+ dodoc CHANGELOG README
+}