summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-11-02 21:14:16 +0000
committerMichał Górny <mgorny@gentoo.org>2010-11-02 21:14:16 +0000
commit3a55bacdb461f333132b681342bd1a0d1f886494 (patch)
treed7852f9cdbc3faab0a4c08361ba21546ad813aec /app-text/wklej/wklej-0.2.1.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3a55bacdb461f333132b681342bd1a0d1f886494.tar.gz
gentoo-2-3a55bacdb461f333132b681342bd1a0d1f886494.tar.bz2
gentoo-2-3a55bacdb461f333132b681342bd1a0d1f886494.zip
Version bump per bug #339018. General metadata cleanup, and removed obsolete AUX file.
(Portage version: 2.2.0_alpha3_p1/cvs/Linux x86_64)
Diffstat (limited to 'app-text/wklej/wklej-0.2.1.ebuild')
-rw-r--r--app-text/wklej/wklej-0.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/wklej/wklej-0.2.1.ebuild b/app-text/wklej/wklej-0.2.1.ebuild
new file mode 100644
index 000000000000..7abf6361033e
--- /dev/null
+++ b/app-text/wklej/wklej-0.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wklej/wklej-0.2.1.ebuild,v 1.1 2010/11/02 21:14:16 mgorny Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="*:2.6"
+inherit eutils python
+
+DESCRIPTION="A wklej.org submitter"
+HOMEPAGE="http://wklej.org"
+SRC_URI="http://wklej.org/m/apps/wklej-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+vim"
+
+DEPEND=""
+RDEPEND="vim? ( app-editors/vim[python] )"
+
+S=${WORKDIR}
+
+src_install() {
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins ${PN}.vim || die
+ fi
+
+ dobin ${PN} || die
+ dodoc README wklejrc || die
+}