summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-06-04 13:59:54 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-06-04 13:59:54 +0000
commit4eca2475f4ae881ce0cea203a102e8c46edc4b20 (patch)
tree35f3680ad09c2ab9bfe0061cfb85a48ae9236b0d /app-text/sloccount/sloccount-2.22.ebuild
parentInitial import (diff)
downloadgentoo-2-4eca2475f4ae881ce0cea203a102e8c46edc4b20.tar.gz
gentoo-2-4eca2475f4ae881ce0cea203a102e8c46edc4b20.tar.bz2
gentoo-2-4eca2475f4ae881ce0cea203a102e8c46edc4b20.zip
Initial import
Diffstat (limited to 'app-text/sloccount/sloccount-2.22.ebuild')
-rw-r--r--app-text/sloccount/sloccount-2.22.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/sloccount/sloccount-2.22.ebuild b/app-text/sloccount/sloccount-2.22.ebuild
new file mode 100644
index 000000000000..8cfb27d75466
--- /dev/null
+++ b/app-text/sloccount/sloccount-2.22.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sloccount/sloccount-2.22.ebuild,v 1.1 2003/06/04 13:59:17 lu_zero Exp $
+
+DESCRIPTION="A set of tools for counting physical Source Lines of Code (SLOC) in a large number of languages of a potentially large set of programs."
+
+HOMEPAGE="http://www.dwheeler.com/sloccount/"
+
+SRC_URI="http://www.dwheeler.com/sloccount/${P}.tar.gz"
+
+LICENSE="GPL-1"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="dev-lang/perl
+ app-shells/bash"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S};
+
+ # Patch to move most of the executables out of /usr/bin
+ # and into /usr/libexec/sloccount to avoid conflicts.
+ epatch ${FILESDIR}/${P}-libexec.patch
+}
+
+src_compile() {
+ make -f makefile PREFIX=/usr
+}
+
+src_install() {
+ make -f makefile install PREFIX=${D}/usr
+}