summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-25 12:05:34 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-25 12:05:34 +0000
commit1c1dd8662abd8308c7286d57750b14942eaf24b7 (patch)
tree1ebf221bf59c0d101aacf1c22db037b4a17967bf /app-text/sgmltools-lite
parentStable for ia64, wrt bug #491270 (diff)
downloadgentoo-2-1c1dd8662abd8308c7286d57750b14942eaf24b7.tar.gz
gentoo-2-1c1dd8662abd8308c7286d57750b14942eaf24b7.tar.bz2
gentoo-2-1c1dd8662abd8308c7286d57750b14942eaf24b7.zip
Convert to python-single-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-text/sgmltools-lite')
-rw-r--r--app-text/sgmltools-lite/ChangeLog10
-rw-r--r--app-text/sgmltools-lite/sgmltools-lite-3.0.3-r12.ebuild101
2 files changed, 109 insertions, 2 deletions
diff --git a/app-text/sgmltools-lite/ChangeLog b/app-text/sgmltools-lite/ChangeLog
index d95483ece71d..d8a586f084e9 100644
--- a/app-text/sgmltools-lite/ChangeLog
+++ b/app-text/sgmltools-lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/sgmltools-lite
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sgmltools-lite/ChangeLog,v 1.62 2013/07/21 10:09:50 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgmltools-lite/ChangeLog,v 1.63 2014/12/25 12:05:34 mgorny Exp $
+
+*sgmltools-lite-3.0.3-r12 (25 Dec 2014)
+
+ 25 Dec 2014; Michał Górny <mgorny@gentoo.org>
+ +sgmltools-lite-3.0.3-r12.ebuild:
+ Convert to python-single-r1.
21 Jul 2013; Pacho Ramos <pacho@gentoo.org> -sgmltools-lite-3.0.3-r10.ebuild,
metadata.xml:
diff --git a/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r12.ebuild b/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r12.ebuild
new file mode 100644
index 000000000000..601c72479979
--- /dev/null
+++ b/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r12.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sgmltools-lite/sgmltools-lite-3.0.3-r12.ebuild,v 1.1 2014/12/25 12:05:34 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 sgml-catalog
+
+DESCRIPTION="Python interface to SGML software in a DocBook/OpenJade env"
+HOMEPAGE="http://sgmltools-lite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sgmltools-lite/${P}.tar.gz
+ mirror://sourceforge/sgmltools-lite/nw-eps-icons-0.0.1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="jadetex"
+
+RDEPEND="${PYTHON_DEPS}
+ app-text/sgml-common
+ app-text/docbook-sgml-dtd:3.1
+ app-text/docbook-dsssl-stylesheets
+ app-text/openjade
+ jadetex? ( app-text/jadetex )
+ || (
+ www-client/w3m
+ www-client/lynx )"
+DEPEND=${RDEPEND}
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+sgml-catalog_cat_include "/etc/sgml/sgml-lite.cat" \
+ "/usr/share/sgml/stylesheets/sgmltools/sgmltools.cat"
+
+src_prepare() {
+ # Remove CVS directories from the tree
+ find . -name CVS -exec rm -rf {} + || die
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ einstall etcdir="${D}"/etc/sgml || die
+
+ dodoc ChangeLog POSTINSTALL README*
+ dohtml -r .
+
+ cd "${WORKDIR}"/nw-eps-icons-0.0.1/images
+ insinto /usr/share/sgml/docbook/dsssl-stylesheets/images
+ doins *.eps
+
+ cd callouts
+ insinto /usr/share/sgml/docbook/dsssl-stylesheets/images/callouts
+ doins *.eps
+
+ rm "${D}"/etc/sgml/catalog.{suse,rh62}
+
+ # Remove file provided by sgml-common
+ rm "${D}"/usr/bin/sgmlwhich
+
+ # Remove the backends that require jadetex
+ use jadetex || \
+ rm "${D}"/usr/share/sgml/misc/sgmltools/python/backends/{Dvi,Ps,Pdf,JadeTeX}.py
+
+ # List of backends to alias with sgml2*
+ # Do not provide sgml2{txt,rtf,html} anymore, they are part of
+ # linuxdoc-tools
+ local BACKENDS=""
+ use jadetex && BACKENDS="ps dvi pdf"
+
+ # Create simple alias scripts that people are used to
+ # And make the manpages for those link to the sgmltools-lite manpage
+ mandir="${D}"/usr/share/man/man1
+ ScripTEXT="#!/bin/sh\n/usr/bin/sgmltools --backend="
+ for back in ${BACKENDS}
+ do
+ echo -e ${ScripTEXT}${back} '$*' > sgml2${back}
+ exeinto /usr/bin
+ doexe sgml2${back}
+
+ cd ${mandir} || die
+ ln -sf sgmltools-lite.1.gz sgml2${back}.1.gz || die
+ cd "${S}" || die
+ done
+
+ python_fix_shebang "${D}"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/sgml/misc/sgmltools/python
+ sgml-catalog_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/sgml/misc/sgmltools/python
+ sgml-catalog_pkg_postrm
+}