summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 17:15:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-08 17:15:13 +0000
commit6f25eb46ea352edfed5900e18c589cf25d083d64 (patch)
treeb491dff83b2558816c3b18c813d7c80a0d624391 /app-text/queequeg
parentarm/s390/sh stable (diff)
downloadgentoo-2-6f25eb46ea352edfed5900e18c589cf25d083d64.tar.gz
gentoo-2-6f25eb46ea352edfed5900e18c589cf25d083d64.tar.bz2
gentoo-2-6f25eb46ea352edfed5900e18c589cf25d083d64.zip
Use Python 2 (bug #312121).
(Portage version: 2.2.0_alpha14/cvs/Linux x86_64)
Diffstat (limited to 'app-text/queequeg')
-rw-r--r--app-text/queequeg/ChangeLog8
-rw-r--r--app-text/queequeg/queequeg-0.91.ebuild37
2 files changed, 32 insertions, 13 deletions
diff --git a/app-text/queequeg/ChangeLog b/app-text/queequeg/ChangeLog
index 866183aaddea..ac1898022956 100644
--- a/app-text/queequeg/ChangeLog
+++ b/app-text/queequeg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/queequeg
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/queequeg/ChangeLog,v 1.8 2010/06/11 21:38:05 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/queequeg/ChangeLog,v 1.9 2011/01/08 17:15:13 arfrever Exp $
+
+ 08 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ queequeg-0.91.ebuild:
+ Use Python 2 (bug #312121).
11 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
queequeg-0.91.ebuild:
diff --git a/app-text/queequeg/queequeg-0.91.ebuild b/app-text/queequeg/queequeg-0.91.ebuild
index e03484c75761..7c2e5f59463d 100644
--- a/app-text/queequeg/queequeg-0.91.ebuild
+++ b/app-text/queequeg/queequeg-0.91.ebuild
@@ -1,24 +1,34 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/queequeg/queequeg-0.91.ebuild,v 1.9 2010/06/11 21:38:05 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/queequeg/queequeg-0.91.ebuild,v 1.10 2011/01/08 17:15:13 arfrever Exp $
-inherit distutils multilib
+EAPI="3"
+PYTHON_DEPEND="2"
-IUSE=""
+inherit python
DESCRIPTION="A checker for English grammar, for people who are not native English."
HOMEPAGE="http://queequeg.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
-DEPEND=">=dev-lang/python-2.3
- app-dicts/wordnet"
+DEPEND="app-dicts/wordnet"
+RDEPEND="${DEPEND}"
-src_compile() {
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r ${PYTHON_ABI} .
+}
+src_compile() {
local dictdir=/usr/dict
if has_version ">=app-dicts/wordnet-2.0"; then
@@ -26,16 +36,14 @@ src_compile() {
fi
emake dict WORDNETDICT=${dictdir} || die
-
}
src_install() {
-
local prefix=$(python_get_sitedir)/${PN}
insinto ${prefix}
doins *.py
- [ -f "dict.txt" ] && doins dict.txt || doins dict.cdb
+ [[ -f "dict.txt" ]] && doins dict.txt || doins dict.cdb
exeinto ${prefix}
doexe qq
@@ -43,5 +51,12 @@ src_install() {
dodoc README TODO
dohtml htdocs/*
+}
+
+pkg_postinst() {
+ python_mod_optimize queequeg
+}
+pkg_postrm() {
+ python_mod_cleanup queequeg
}