summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-08 16:52:17 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-08 16:52:17 +0000
commitcdf597aee9717d3e69591ee1e6d935371e213214 (patch)
treee4ae99fb05ad9d3998ca4860a14568d7677ddb7e /app-text/pylize
parentdrop unused IUSE test, add IUSE doc and doc build & dep sphinx, patch for doc... (diff)
downloadgentoo-2-cdf597aee9717d3e69591ee1e6d935371e213214.tar.gz
gentoo-2-cdf597aee9717d3e69591ee1e6d935371e213214.tar.bz2
gentoo-2-cdf597aee9717d3e69591ee1e6d935371e213214.zip
Convert to distutils-r1. Fix PIL imports, bug 471502.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-text/pylize')
-rw-r--r--app-text/pylize/ChangeLog11
-rw-r--r--app-text/pylize/files/pylize-pillow.patch13
-rw-r--r--app-text/pylize/pylize-1.3b-r1.ebuild47
3 files changed, 68 insertions, 3 deletions
diff --git a/app-text/pylize/ChangeLog b/app-text/pylize/ChangeLog
index 068804f2f419..0828a32ebc40 100644
--- a/app-text/pylize/ChangeLog
+++ b/app-text/pylize/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pylize
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pylize/ChangeLog,v 1.13 2010/03/29 20:50:03 arfrever Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pylize/ChangeLog,v 1.14 2013/06/08 16:52:17 floppym Exp $
+
+*pylize-1.3b-r1 (08 Jun 2013)
+
+ 08 Jun 2013; Mike Gilbert <floppym@gentoo.org> +files/pylize-pillow.patch,
+ +pylize-1.3b-r1.ebuild:
+ Convert to distutils-r1. Fix PIL imports, bug 471502.
29 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pylize-1.3b.ebuild:
@@ -42,4 +48,3 @@
08 Mar 2003; Alastair Tse <liquidx@gentoo.org> pylize-1.1b.ebuild:
intial import. bug #10655.
-
diff --git a/app-text/pylize/files/pylize-pillow.patch b/app-text/pylize/files/pylize-pillow.patch
new file mode 100644
index 000000000000..0b454b0b1712
--- /dev/null
+++ b/app-text/pylize/files/pylize-pillow.patch
@@ -0,0 +1,13 @@
+Change PIL imports for Pillow compat
+https://bugs.gentoo.org/show_bug.cgi?id=471502
+--- a/pylize.in
++++ b/pylize.in
+@@ -113,7 +113,7 @@
+ def mkLogoLink(meta):
+ if meta.has_key('logo'):
+ try:
+- import Image
++ from PIL import Image
+ if os.path.exists(meta['logo']):
+ i = Image.open(meta['logo'])
+ else:
diff --git a/app-text/pylize/pylize-1.3b-r1.ebuild b/app-text/pylize/pylize-1.3b-r1.ebuild
new file mode 100644
index 000000000000..48a26b265c4e
--- /dev/null
+++ b/app-text/pylize/pylize-1.3b-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pylize/pylize-1.3b-r1.ebuild,v 1.1 2013/06/08 16:52:17 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Python HTML Slideshow Generator using HTML and CSS"
+HOMEPAGE="http://www.chrisarndt.de/en/software/pylize/"
+SRC_URI="http://www.chrisarndt.de/en/software/pylize/download/${P}.tar.bz2"
+
+IUSE="doc"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-python/empy[${PYTHON_USEDEP}]
+ dev-python/imaging[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-pillow.patch" )
+
+python_configure() {
+ set -- "${PYTHON}" configure.py
+ echo "$@"
+ "$@" || die
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc PYTHON="${PYTHON}" PYLIZE="../pylize" || die
+ fi
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize "${ED%/}/usr/share/pylize"
+}
+
+python_install_all() {
+ local DOCS=( Changelog README README.empy TODO )
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}