summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2013-04-14 20:02:59 +0000
committerZac Medico <zmedico@gentoo.org>2013-04-14 20:02:59 +0000
commit3b6c35ae775babc42418cd57ee349a4709b3f6b4 (patch)
tree404a13719eef7d970183038ab97015e391272a17 /app-text/podofo
parentStable for ia64, wrt bug #465926 (diff)
downloadgentoo-2-3b6c35ae775babc42418cd57ee349a4709b3f6b4.tar.gz
gentoo-2-3b6c35ae775babc42418cd57ee349a4709b3f6b4.tar.bz2
gentoo-2-3b6c35ae775babc42418cd57ee349a4709b3f6b4.zip
Bump to EAPI 5 for slot-operator deps.
(Portage version: 2.2.0_alpha173/cvs/Linux i686, signed Manifest commit with key 0xFDE8EF85AE5719A3)
Diffstat (limited to 'app-text/podofo')
-rw-r--r--app-text/podofo/ChangeLog5
-rw-r--r--app-text/podofo/podofo-0.9.2.ebuild26
2 files changed, 16 insertions, 15 deletions
diff --git a/app-text/podofo/ChangeLog b/app-text/podofo/ChangeLog
index 85f658e4dd2c..ec32ed079f22 100644
--- a/app-text/podofo/ChangeLog
+++ b/app-text/podofo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/podofo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.40 2013/04/10 17:08:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.41 2013/04/14 20:02:59 zmedico Exp $
+
+ 14 Apr 2013; Zac Medico <zmedico@gentoo.org> podofo-0.9.2.ebuild:
+ Bump to EAPI 5 for slot-operator deps.
10 Apr 2013; Jeroen Roovers <jer@gentoo.org> podofo-0.9.2.ebuild:
Stable for HPPA (bug #464416).
diff --git a/app-text/podofo/podofo-0.9.2.ebuild b/app-text/podofo/podofo-0.9.2.ebuild
index dead3119e2bf..5e3b2bed31b1 100644
--- a/app-text/podofo/podofo-0.9.2.ebuild
+++ b/app-text/podofo/podofo-0.9.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.2.ebuild,v 1.8 2013/04/10 17:08:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.2.ebuild,v 1.9 2013/04/14 20:02:59 zmedico Exp $
-EAPI=2
+EAPI=5
inherit cmake-utils flag-o-matic multilib toolchain-funcs
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
@@ -14,15 +14,15 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 ~sparc x86"
IUSE="+boost idn debug test"
-RDEPEND="dev-lang/lua
- idn? ( net-dns/libidn )
- dev-libs/openssl
- media-libs/fontconfig
- media-libs/freetype:2
- virtual/jpeg
- >=media-libs/libpng-1.4:0
- media-libs/tiff:0
- sys-libs/zlib"
+RDEPEND="dev-lang/lua:=
+ idn? ( net-dns/libidn:= )
+ dev-libs/openssl:=
+ media-libs/fontconfig:=
+ media-libs/freetype:2=
+ virtual/jpeg:=
+ >=media-libs/libpng-1.4:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
DEPEND="${RDEPEND}
virtual/pkgconfig
boost? ( dev-util/boost-build )
@@ -35,11 +35,9 @@ src_prepare() {
sed -i \
-e "s:LIBDIRNAME \"lib\":LIBDIRNAME \"$(get_libdir)\":" \
+ -e "s:LIBIDN_FOUND:HAVE_LIBIDN:g" \
CMakeLists.txt || die
- sed -i \
- -e "s:LIBIDN_FOUND:HAVE_LIBIDN:g" CMakeLists.txt || die
-
# Use pkg-config to find headers for bug #459404.
sed_args=
for x in $($(tc-getPKG_CONFIG) --cflags freetype2) ; do