summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-09-05 20:03:36 +0000
committerZac Medico <zmedico@gentoo.org>2011-09-05 20:03:36 +0000
commita00cc928e1e8d879f8d2aefc61e464db1e9538d1 (patch)
tree77b4355ecb95b146e293ac2be59fd1d61e8532aa /app-text/podofo/podofo-0.9.1.ebuild
parentRevision bump for new patchset. (diff)
downloadgentoo-2-a00cc928e1e8d879f8d2aefc61e464db1e9538d1.tar.gz
gentoo-2-a00cc928e1e8d879f8d2aefc61e464db1e9538d1.tar.bz2
gentoo-2-a00cc928e1e8d879f8d2aefc61e464db1e9538d1.zip
Bug #381359 - undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()' triggered by -fvisibility-inlines-hidden in CXXFLAGS.
(Portage version: 2.2.0_alpha53/cvs/Linux i686)
Diffstat (limited to 'app-text/podofo/podofo-0.9.1.ebuild')
-rw-r--r--app-text/podofo/podofo-0.9.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-text/podofo/podofo-0.9.1.ebuild b/app-text/podofo/podofo-0.9.1.ebuild
index 99db053e8ba2..4f8f2b5d1465 100644
--- a/app-text/podofo/podofo-0.9.1.ebuild
+++ b/app-text/podofo/podofo-0.9.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.1.ebuild,v 1.1 2011/05/09 08:06:31 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.9.1.ebuild,v 1.2 2011/09/05 20:03:36 zmedico Exp $
EAPI=2
-inherit cmake-utils eutils multilib
+inherit cmake-utils flag-o-matic multilib
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
HOMEPAGE="http://sourceforge.net/projects/podofo/"
@@ -66,6 +66,10 @@ src_prepare() {
}
src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
mycmakeargs+=(
"-DPODOFO_BUILD_SHARED=1"
"-DPODOFO_HAVE_JPEG_LIB=1"