summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-06-19 06:07:54 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-06-19 06:07:54 +0000
commite16820d0fb7736b762fba3ba2dd066eb80f4d52f (patch)
treeebe4fe9dbf52362cc095537473b93999a5d384bf /app-text/pandoc
parentVersion bump (diff)
downloadgentoo-2-e16820d0fb7736b762fba3ba2dd066eb80f4d52f.tar.gz
gentoo-2-e16820d0fb7736b762fba3ba2dd066eb80f4d52f.tar.bz2
gentoo-2-e16820d0fb7736b762fba3ba2dd066eb80f4d52f.zip
fix pandoc-1.11.1 test failure, thanks slyfox for the report
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'app-text/pandoc')
-rw-r--r--app-text/pandoc/ChangeLog6
-rw-r--r--app-text/pandoc/files/pandoc-1.11.1-test.patch42
-rw-r--r--app-text/pandoc/pandoc-1.11.1.ebuild3
3 files changed, 49 insertions, 2 deletions
diff --git a/app-text/pandoc/ChangeLog b/app-text/pandoc/ChangeLog
index 88d8a2733999..bdc33607af82 100644
--- a/app-text/pandoc/ChangeLog
+++ b/app-text/pandoc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/pandoc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.15 2013/04/02 13:05:32 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.16 2013/06/19 06:07:54 qnikst Exp $
+
+ 19 Jun 2013; Alexander Vershilov <qnikst@gentoo.org>
+ +files/pandoc-1.11.1-test.patch, pandoc-1.11.1.ebuild:
+ fix pandoc-1.11.1 test failure, thanks slyfox for the report
*pandoc-1.11.1 (02 Apr 2013)
diff --git a/app-text/pandoc/files/pandoc-1.11.1-test.patch b/app-text/pandoc/files/pandoc-1.11.1-test.patch
new file mode 100644
index 000000000000..d5d1e894d505
--- /dev/null
+++ b/app-text/pandoc/files/pandoc-1.11.1-test.patch
@@ -0,0 +1,42 @@
+commit fa978e13658f76be109243224f7491550db74240
+Author: John MacFarlane <fiddlosopher@gmail.com>
+Date: Tue May 7 20:22:09 2013 -0700
+
+ Use latest highlighting-kate and texmath.
+
+ Closes #849.
+
+diff --git a/pandoc.cabal b/pandoc.cabal
+index 5f290a9..ea9e850 100644
+--- a/pandoc.cabal
++++ b/pandoc.cabal
+@@ -241,7 +241,7 @@ Library
+ old-locale >= 1 && < 1.1,
+ time >= 1.2 && < 1.5,
+ HTTP >= 4000.0.5 && < 4000.3,
+- texmath >= 0.6.1.3 && < 0.7,
++ texmath >= 0.6.1.5 && < 0.7,
+ xml >= 1.3.12 && < 1.4,
+ random >= 1 && < 1.1,
+ extensible-exceptions >= 0.1 && < 0.2,
+@@ -251,7 +251,7 @@ Library
+ tagsoup >= 0.12.5 && < 0.13,
+ base64-bytestring >= 0.1 && < 1.1,
+ zlib >= 0.5 && < 0.6,
+- highlighting-kate >= 0.5.3.7 && < 0.6,
++ highlighting-kate >= 0.5.3.9 && < 0.6,
+ data-default >= 0.4 && < 0.6,
+ temporary >= 1.1 && < 1.2,
+ blaze-html >= 0.5 && < 0.7,
+diff --git a/tests/lhs-test.latex b/tests/lhs-test.latex
+index 16e9a79..2a5025a 100644
+--- a/tests/lhs-test.latex
++++ b/tests/lhs-test.latex
+@@ -22,6 +22,7 @@
+ \IfFileExists{microtype.sty}{\usepackage{microtype}}{}
+ \usepackage{color}
+ \usepackage{fancyvrb}
++\newcommand{\VerbBar}{|}
+ \DefineShortVerb[commandchars=\\\{\}]{\|}
+ \DefineVerbatimEnvironment{Highlighting}{Verbatim}{commandchars=\\\{\}}
+ % Add ',fontsize=\small' for more characters per line
diff --git a/app-text/pandoc/pandoc-1.11.1.ebuild b/app-text/pandoc/pandoc-1.11.1.ebuild
index bd29de1c180e..457595cee55e 100644
--- a/app-text/pandoc/pandoc-1.11.1.ebuild
+++ b/app-text/pandoc/pandoc-1.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.11.1.ebuild,v 1.1 2013/04/02 13:05:31 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.11.1.ebuild,v 1.2 2013/06/19 06:07:54 qnikst Exp $
EAPI=5
@@ -77,6 +77,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-no-man-tests.patch
+ epatch "${FILESDIR}"/${P}-test.patch
ghc-supports-threaded-runtime ||
cabal_chdeps \