summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 09:37:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-09-13 09:37:02 +0000
commit70998dd3cede1913c688c1ce763bc4be83e1c5c1 (patch)
tree02096231be935b293aa78d305e3b87819862fb01 /app-text/libmspub
parentAdd epatch_user in the modern ebuilds. (diff)
downloadgentoo-2-70998dd3cede1913c688c1ce763bc4be83e1c5c1.tar.gz
gentoo-2-70998dd3cede1913c688c1ce763bc4be83e1c5c1.tar.bz2
gentoo-2-70998dd3cede1913c688c1ce763bc4be83e1c5c1.zip
Version bump. Thanks to Andreas Sturmlechner.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text/libmspub')
-rw-r--r--app-text/libmspub/ChangeLog10
-rw-r--r--app-text/libmspub/libmspub-0.1.1.ebuild53
-rw-r--r--app-text/libmspub/libmspub-9999.ebuild15
3 files changed, 68 insertions, 10 deletions
diff --git a/app-text/libmspub/ChangeLog b/app-text/libmspub/ChangeLog
index 29f5f97ed3c5..d0725f65830f 100644
--- a/app-text/libmspub/ChangeLog
+++ b/app-text/libmspub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/libmspub
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/ChangeLog,v 1.12 2013/07/09 06:15:44 scarabeus Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/ChangeLog,v 1.13 2014/09/13 09:37:02 dilfridge Exp $
+
+*libmspub-0.1.1 (13 Sep 2014)
+
+ 13 Sep 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libmspub-0.1.1.ebuild, libmspub-9999.ebuild:
+ Version bump. Thanks to Andreas Sturmlechner.
09 Jul 2013; Tomáš Chvátal <scarabeus@gentoo.org> libmspub-9999.ebuild:
Fix wrong inherit order wrt bug#476204.
diff --git a/app-text/libmspub/libmspub-0.1.1.ebuild b/app-text/libmspub/libmspub-0.1.1.ebuild
new file mode 100644
index 000000000000..feb5d1b81d9d
--- /dev/null
+++ b/app-text/libmspub/libmspub-0.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/libmspub-0.1.1.ebuild,v 1.1 2014/09/13 09:37:02 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/${PN}/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing Microsoft Publisher documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/boost
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ base_src_prepare
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libmspub/libmspub-9999.ebuild b/app-text/libmspub/libmspub-9999.ebuild
index 03c215a4093f..79226bdd03aa 100644
--- a/app-text/libmspub/libmspub-9999.ebuild
+++ b/app-text/libmspub/libmspub-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/libmspub-9999.ebuild,v 1.6 2013/07/09 06:15:44 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmspub/libmspub-9999.ebuild,v 1.7 2014/09/13 09:37:02 dilfridge Exp $
EAPI=5
@@ -8,23 +8,22 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/${PN}/"
inherit base eutils
[[ ${PV} == 9999 ]] && inherit autotools git-2
-DESCRIPTION="Library parsing the Microsoft Publisher documents"
-HOMEPAGE="http://www.freedesktop.org/wiki/Software/libmspub"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+DESCRIPTION="Library parsing Microsoft Publisher documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
RDEPEND="
- app-text/libwpd:0.9
- app-text/libwpg:0.2
dev-libs/icu:=
+ dev-libs/librevenge
sys-libs/zlib
"
DEPEND="${RDEPEND}