summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-06 15:30:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-06 15:30:46 +0000
commit634f28d78299f42670f914216692155ee79a5731 (patch)
treeca7ccca9f261ce0a5de7d4055b7e26b23de1a77c /app-text/ispell
parentwhitespace (diff)
downloadgentoo-2-634f28d78299f42670f914216692155ee79a5731.tar.gz
gentoo-2-634f28d78299f42670f914216692155ee79a5731.tar.bz2
gentoo-2-634f28d78299f42670f914216692155ee79a5731.zip
Fix building with GLIBC 2.10+ wrt #272362.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-text/ispell')
-rw-r--r--app-text/ispell/ChangeLog8
-rw-r--r--app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch48
-rw-r--r--app-text/ispell/ispell-3.3.02-r1.ebuild14
3 files changed, 62 insertions, 8 deletions
diff --git a/app-text/ispell/ChangeLog b/app-text/ispell/ChangeLog
index b73310058513..029b1fa93df7 100644
--- a/app-text/ispell/ChangeLog
+++ b/app-text/ispell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ispell
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.36 2008/11/01 08:14:41 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ChangeLog,v 1.37 2009/08/06 15:30:46 ssuominen Exp $
+
+ 06 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ ispell-3.3.02-r1.ebuild, +files/ispell-3.3.02-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #272362.
*ispell-3.3.02-r1 (01 Nov 2008)
diff --git a/app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch b/app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch
new file mode 100644
index 000000000000..8ccd5cc78855
--- /dev/null
+++ b/app-text/ispell/files/ispell-3.3.02-glibc-2.10.patch
@@ -0,0 +1,48 @@
+diff -ur ispell-3.3.02.orig/correct.c ispell-3.3.02/correct.c
+--- ispell-3.3.02.orig/correct.c 2009-08-06 18:28:32.000000000 +0300
++++ ispell-3.3.02/correct.c 2009-08-06 18:28:57.000000000 +0300
+@@ -247,7 +247,7 @@
+ struct flagent * sufent,
+ ichar_t savearea[MAX_CAPS][INPUTWORDLEN + MAXAFFIXLEN],
+ int * nsaved));
+-static char * getline P ((char * buf, int bufsize));
++static char * get_line P ((char * buf, int bufsize));
+ void askmode P ((void));
+ void copyout P ((unsigned char ** cc, int cnt));
+ static void lookharder P ((unsigned char * string));
+@@ -573,7 +573,7 @@
+
+ imove (li - 1, 0);
+ (void) putchar ('!');
+- if (getline ((char *) buf, sizeof buf) == NULL)
++ if (get_line ((char *) buf, sizeof buf) == NULL)
+ {
+ (void) putchar (7);
+ ierase ();
+@@ -598,7 +598,7 @@
+ (void) printf ("%s ", CORR_C_READONLY);
+ }
+ (void) printf (CORR_C_REPLACE_WITH);
+- if (getline ((char *) ctok, ctokl) == NULL)
++ if (get_line ((char *) ctok, ctokl) == NULL)
+ {
+ (void) putchar (7);
+ /* Put it back */
+@@ -666,7 +666,7 @@
+ unsigned char buf[100];
+ imove (li - 1, 0);
+ (void) printf (CORR_C_LOOKUP_PROMPT);
+- if (getline ((char *) buf, sizeof buf) == NULL)
++ if (get_line ((char *) buf, sizeof buf) == NULL)
+ {
+ (void) putchar (7);
+ ierase ();
+@@ -1585,7 +1585,7 @@
+ return;
+ }
+
+-static char * getline (s, len)
++static char * get_line (s, len)
+ register char * s;
+ register int len;
+ {
diff --git a/app-text/ispell/ispell-3.3.02-r1.ebuild b/app-text/ispell/ispell-3.3.02-r1.ebuild
index 80a62eca2e16..1661ab86d860 100644
--- a/app-text/ispell/ispell-3.3.02-r1.ebuild
+++ b/app-text/ispell/ispell-3.3.02-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.3.02-r1.ebuild,v 1.1 2008/11/01 08:14:41 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.3.02-r1.ebuild,v 1.2 2009/08/06 15:30:46 ssuominen Exp $
inherit eutils multilib toolchain-funcs
@@ -10,18 +10,20 @@ HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
mirror://gentoo/${P}-gentoo-${PATCH_VER}.diff.bz2"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
IUSE=""
-DEPEND="sys-apps/miscfiles
- >=sys-libs/ncurses-5.2"
+RDEPEND="sys-apps/miscfiles
+ >=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${WORKDIR}/${P}-gentoo-${PATCH_VER}.diff"
+ epatch "${WORKDIR}"/${P}-gentoo-${PATCH_VER}.diff
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
sed -e "s:GENTOO_LIBDIR:$(get_libdir):" -i local.h || die
sed -e "s:\(^#define CC\).*:\1 \"$(tc-getCC)\":" -i local.h || die