summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-01-26 17:02:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-01-26 17:02:47 +0000
commit0627f2a799dda5e13f254e52aca57b9f04b43a9d (patch)
tree73a4ad04117797e181c1c276619537da9b6abcc6 /app-text/gocr/gocr-0.45.ebuild
parentalpha/sparc/x86 stable, remove old (diff)
downloadgentoo-2-0627f2a799dda5e13f254e52aca57b9f04b43a9d.tar.gz
gentoo-2-0627f2a799dda5e13f254e52aca57b9f04b43a9d.tar.bz2
gentoo-2-0627f2a799dda5e13f254e52aca57b9f04b43a9d.zip
version bump
(Portage version: 2.1.4)
Diffstat (limited to 'app-text/gocr/gocr-0.45.ebuild')
-rw-r--r--app-text/gocr/gocr-0.45.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/gocr/gocr-0.45.ebuild b/app-text/gocr/gocr-0.45.ebuild
new file mode 100644
index 000000000000..8b6e6c119513
--- /dev/null
+++ b/app-text/gocr/gocr-0.45.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.45.ebuild,v 1.1 2008/01/26 17:02:46 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE="doc tk"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 virtual/ghostscript )
+ tk? ( dev-lang/tk )"
+
+DOCS="AUTHORS BUGS CREDITS HISTORY RE* TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ econf || die "econf failed"
+ emake ${mymakes} || die "make ${mymakes} failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="/usr" exec_prefix="/usr" install || die "make install failed"
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${D}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ DOCS="${DOCS} doc/gocr.html doc/examples.txt doc/unicode.txt"
+ insinto /usr/share/doc/${P}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ fi
+ # and then install all the docs
+ dodoc ${DOCS}
+}