summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-24 20:57:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-24 20:57:12 +0000
commitcb5c16556c42d10c00a0524cd22747afa6529915 (patch)
tree10e9370b874d0895af3b37b178a165f24e8dbdba /app-text/evince
parentBump, bug 248065. Thanks to billie (Daniel Pielmeier). (diff)
downloadgentoo-2-cb5c16556c42d10c00a0524cd22747afa6529915.tar.gz
gentoo-2-cb5c16556c42d10c00a0524cd22747afa6529915.tar.bz2
gentoo-2-cb5c16556c42d10c00a0524cd22747afa6529915.zip
Bump to 2.24.2. Bug fixes and translation updates.
(Portage version: 2.2_rc15/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog7
-rw-r--r--app-text/evince/evince-2.24.2.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index aef5579f30e8..9850add4efe2 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/evince
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.157 2008/11/19 23:52:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.158 2008/11/24 20:57:12 eva Exp $
+
+*evince-2.24.2 (24 Nov 2008)
+
+ 24 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org> +evince-2.24.2.ebuild:
+ Bump to 2.24.2. Bug fixes and translation updates.
*evince-2.24.1 (20 Nov 2008)
diff --git a/app-text/evince/evince-2.24.2.ebuild b/app-text/evince/evince-2.24.2.ebuild
new file mode 100644
index 000000000000..1061a9b879bf
--- /dev/null
+++ b/app-text/evince/evince-2.24.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-2.24.2.ebuild,v 1.1 2008/11/24 20:57:12 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug djvu doc dvi gnome-keyring nautilus t1lib tiff"
+
+RDEPEND="
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.15.6
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.20.1 )
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=dev-libs/libxml2-2.5
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2
+ nautilus? ( >=gnome-base/nautilus-2.10 )
+ >=app-text/poppler-bindings-0.8
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5.0.0 )
+ )
+ tiff? ( >=media-libs/tiff-3.6 )
+ djvu? ( >=app-text/djvu-3.5.17 )
+ >=app-text/libspectre-0.2.0"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( dev-util/gtk-doc )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+ELTCONF="--portage"
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ --enable-comics
+ --enable-impress
+ --enable-thumbnailer
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome-keyring keyring)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable nautilus)"
+
+ if ! built_with_use app-text/poppler-bindings gtk cairo; then
+ eerror "Please re-emerge app-text/poppler-bindings with the gtk and cairo USE flag set"
+ die "poppler-bindings needs gtk and cairo flags set"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+}